Windows does not detect my SATA drive, but i can see it in BIOS



I have a really annoying situation I'm hoping someone might be able to help me with!? I have inherited a computer (unsure of the exact specs I'm afraid, but it's around 3 or 4 years old, and not ancient). The guy who gave it to me wanted to keep the content on his hard drive, so I was given the rest of it and just had to buy myself a new hard drive. I did, and have connected it all up, but when I try to install Windows, it does not find any hard drives. I checked in BIOS, and I can see it as my master drive there. I've no idea what to do!?

No, you do NOT have to Format first. The Windows Install disk will do all the Partitioning and Formatting you need before doing the actual installation. You have some different issues, probably in configuring things in the BIOS setup.

So, most important first question: what type of hard drive? And, what mobo port connector is it hooked up to?

IF this an IDE drive, the jumper(s) on it need to be set correctly, and the data ribbon cable attached properly. (Since you used the term "master drive", I'm mentioning IDE because the term Master is used ONLY in IDE drives.) On any one IDE channel you can have up to 2 devices sharing the port and ribbon data cable. One of the devices MUST have its jumper set to Master, and it ought to be plugged into the END (BLACK) connector. IF you have a second device on the middle (gray) connector, it MUST be the Slave. If you have both a hard drive and an optical unit sharing a cable, the HDD should be the Master on the end, and the optical set to Slave.

IF the hard drive is SATA, there are NO jumpers to set, and there is no such thing as a Master or Slave in SATA. However, sometimes the words in the BIOS screens are deceptive. Some BIOS's label the SATA ports as if they were extra IDE ports, and refer to the drives connected there as "Channel 3 Master", "Channel 4 Master", etc. - note that there are no Slaves on the Channels after the first two (IDE) channels. It is best to connect the only SATA HDD in the system to the first SATA port.

BY the way, check if there are two groups of SATA ports. Some systems have four or six main SATA ports provided by the mobo's southbridge controller, plus an additional couple provided by an extra SATA controller chip. Usually in those systems the board wants to boot only from a SATA port in the main group, and prefers the first one in that group.

There is ONE possible need to set a jumper on a SATA drive. All SATA systems are supposed to be backward compatible and make adjustments automatically. BUT some people have had problems with a specific combination: a newer SATA II (3.0 Gb/s) hard drive connected to an original (1.5 Gb/s) SATA port. In that situation some of those drives fail to slow themselves down to the port's speed and communication fails. For that situation most HDD makers have a way to force the drive to slow down. Seagate and WD (and others) do this by placing a jumper on a specific pin pair on the back edge of the drive unit. Some drives even arrive with this jumper in place. IF you believe you have this combination of hardware, check the HDD maker's website for how to force the drive to slow down to 1.5 Gb/s. Do NOT change any other jumpers on a SATA drive.

Now, time to check the BIOS settings. You say you can "see" the drive in BIOS as a "master". Wherever it is, check that the port is Enabled (probably is already). If it is a SATA drive, check very near there for a SATA Port Mode setting. IF you are trying to install Win XP, set that to IDE (or PATA) Emulation. On the other hand, if you have Vista or Win 7 to install, set that to AHCI. Now, in the BIOS screens go to where the Boot Priority Sequence is set. Set that to the optical drive first, then the HDD you have just configured, and no other devices. Save and Exit to make these changes permanent. Make sure your Win Install disk is in the optical drive so it will boot from there.

Similar threads