Question Windows Explorer crash and restart issue

thomasgreco0499

Commendable
May 19, 2019
26
0
1,530
0
Hi all.

In April I built a new PC (5900x, 3080, x570, 32 gb ddr4). The system ran fine for months, and still runs fine. However, in July, I started getting an issue where the screen would occasionally (maybe once a day) flash white and windows night light would restart. This entire process happens in less than a second. The issue is exactly what happens when windows explorer.exe crashes and restarts (you can force this to happen in the task manager), and I also know this because the screen flash/explorer restart causes the Nvidia Control Panel icon to disappear from the system tray, which also only happens when Windows Explorer.exe crashes and restarts. Interestingly, no event viewer entry is generating noting that explorer crashed.

I was able to solve the issue for about 1.5 months by updating my bios, reinstalling windows, graphics driver, etc. However, even on the new bios, the issue is now back. My screen flashed again this morning. This is quite annoying so I am trying to solve the issue. Any help is greatly appreciated. Thank you.
 

Lutfij

Titan
Moderator
Can you elaborate on your system's specs? It's best if you mentioned the make and models of your:
Motherboard:
Ram:
GPU:
SSD/HDD:
PSU:

Additionally include the BIOS version. What version(not edition) of Windows 10 are you on?
 

thomasgreco0499

Commendable
May 19, 2019
26
0
1,530
0
Can you elaborate on your system's specs? It's best if you mentioned the make and models of your:
Motherboard:
Ram:
GPU:
SSD/HDD:
PSU:

Additionally include the BIOS version. What version(not edition) of Windows 10 are you on?
Hi. Thanks for the reply.

OS: Windows 10 21H1 (fully updated to latest non-beta/insider release).

Motherboard: MSI x570 Ace, bios version 7C35v1G1. issue first started happening on 7C35v1F, but after being okay for a month after updating it is now occurring on G1 as well.

RAM: Trident Z Neo 3600 MHz 16-19-19-39, 2x16 gb. This ram has worked for a year and I am currently testing on MemTest86 with no errors so far.

GPU: RTX 3080 Gaming X Trio

SSD: Samsung 970 evo

PSU: EVGA 850W G+ 80+ Gold
 

ASK THE COMMUNITY

TRENDING THREADS