Question Windows Limiting Internet Speed. Maxing out at 15Mbps. Running out of options.

May 7, 2022
2
0
10
0
So I recently moved and signed up for spectrum and purchased their internet gig plan. I never knew my internet on my pc was capped until downloading COD. My download speed on battle.net is 2.03MB/s and took 26 hours of nonstop downloading to finish installing the whole game (196GB). Every other device, even on wifi, tests at 500-700+ Mbps but my pc always tests at 15 max WITH Ethernet connected to router OR modem. I know it is windows itself because I have replaced my previous router and modem with the latest modem and router from Spectrum 2 days ago. I have tried multiple ethernet cables, updated the latest LAN drivers and always keep the pc up to date. I am connected on Marvell AQC111C 5GbE connection on an ROG CROSSHAIR FORMULA VIII. Running windows 10 pro with a ryzen 9 5950x, EVGA 3090 FTW3, 32gb G SKILL royal elite ram. I found another post regarding this same issue and here is what I have tried:

netsh int tcp set global autotuninglevel=disabled

netsh int ip reset resetlog.txt
ipconfig /flushdns
netsh winsock reset

I also disabled then reenabled under my network interface
QoS Packet Scheduler

This worked the first time, and was testing nearly at 900 Mbps speeds then noticed my speeds were back to being capped. Am I missing something in windows that is still messing with the internet speeds?
Any more suggestions?
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Running windows 10 pro
What version(not edition) are you on?

I know it is windows itself
Where did you source the installer for the OS?

ROG CROSSHAIR FORMULA VIII
What BIOS version are you on for your motherboard?

What is the make and model of your existing wireless router? Can you check and see if you have any firmware updates pending for said router?
 
You could confirm it is windows by booting a linux USB image. This should run 100% from the USB stick.
You could also try a very simple tool called IPERF. It is a old line mode command that tests between 2 machines in your house. It should get 900+mbit/sec. This tool is not affect by stuff like browsers or disk files. It pretty much just tests the networks hardware and drivers and it not affected by much else in the machine.

2.5g and 5g port seem to still have strange issues from time to time. If nothing seems to work maybe just buy a simple 1gbit pcie card and see if it is some strangeness with the 5g port.

You have a Asus board which likely means you loaded the bloatware unless you were very careful. They have something called gamerfirst or whatever their current name is. It is based on software called CFOSspeed. Any software similar to this should be uninstalled
 

ASK THE COMMUNITY