Question Windows not recognizing GPU, recognizes display adapter instead

Mar 10, 2019
27
1
35
Hey guys, i'm here once again requesting your precious help.

It's pretty much what the title says, my device manager and GPU-Z only detects the display adapter, and because of that i'm stuck with really low resolutions on the screen and performance is just the same as the IGPU, terrible.

I also can't install any nvidia drivers because i get the message saying that they're not compatible with the current windows version, and that it didn't detect any compatible NVIDIA hardware.

Specs:
Core i5 3330
Nvidia Zotac GT730 (i was using my RX 560 but it died so i just plugged my old gt730 in)
Mobo ASROCK h61m-hg4
Windows 10 version 1809
 
Please can you kindly provide full PC specs ??

-1. "Complete" system specs should ALWAYS be accompanied with any driver, hardware, or performance question. Do not post DXDiag reports as they contain a TON of useless information. Posting a DxDiag in place of a System Spec List tends to ward off potential members from helping you.

Please supply the following system details/information:

(Complete System Specs)
-CPU make and model# (clock speed/voltage, type of cooler, and "Core" temperature @ idle and load)
-Motherboard make & model# (include Bios version if graphics card is not recognized or you are having stability issues)
-RAM (amount, clock speed, model#/link of kit, configuration)
-Graphics card(s) make and model# (clock speed, voltage if modified, Driver version and GPU temp both @ idle and load)
-Power supply make,model#, "AND" age (note if using 110V or 220V A/C input)
-HDD/SSD configuration (ie: Raid setup/ back up/ OS drive/etc..)
-Case/Chasis make,model# (fan make, model#, and configuration if having thermal issues)
-Operating System (If using Windows note Framework and service pack version)
-Monitor make, model#, and resolution (If model# is unknown list resolution and refresh rate)

*If the unit is a "laptop" or "All-in-one" system you must note the make and model# of the unit. Be sure you are ALWAYS using the OEM/manufacturer's Driver updates for the unit.

*If "Crashing":
-Note the nature of the "crash" in detail, as there are several definitions for the word "crash".

*If "performance" related issue:
-Note the "exact" point in which the performance reduction occurred (ie: After Windows update, After Bios update, After Driver update, After thermal system shutdown, After Hardware change/upgrade etc...)

*For diagnostic purposes please disable the following:
-Any/all Antivirus/ Anti-malware software
-Any/all OSD monitoring software
-ALL overclocks outside of factory spec
.
 
Reactions: davew1860
Any know solutions or workarounds?
Unfortunately no. I don't have any concrete solution to this, but some peeps have reported that Installing Windows 7 or 8.1 OS solved their problem. I think some issue lies with the latest version/build of the Windows 10 OS, though I'm NOT fully sure.

Have you tried doing a CLEAN re-install of the GPU drivers, by using the DDU tool ? Remove the previous AMD drivers first, and then do a fresh install. Which GPU driver version did you try to install ? Try some older version, instead of the latest.

https://www.guru3d.com/files-details/display-driver-uninstaller-download.html
 
Reactions: davew1860
Mar 10, 2019
27
1
35
Well It seems my Pc won't boot at all anymore so i guess this problem is irrelevant now.

Anyway, i should say, for science, that this was a fresh OS install And there were no previously installed display driver. I also tried installing several older driver versions and all of then showed the same problema. Aditionally, i tried using Win 8.1, 8 and 7 drivers in compatibility mode and none worked. I don't know How to get a windows 8 to test recognition in older windows versions.
 

LinuxDevice

Respectable
May 20, 2017
330
3
1,965
If the integrated GPU works, but not the PCIe GPU, I would have to wonder if perhaps it is a power supply problem. Much more power is required for the PCIe GPU. Having it stop booting? That makes the power supply more suspicious. Can it boot with the PCIe card removed? What is the PSU?
 
Mar 10, 2019
27
1
35
i'm wasn't booting with the IGPU, i was just comparing the performance of the display adapter to it. The card is connected to the PCI-e and the video cable (and adapter) are plugged in the gt730 DVI connection. Can confirm the system was not using the IGPU to display anything since every reading (MSI afterburner, GPU-Z, device manager) were all detecting the display adapter and not showing intel's on-board GPU, also in GPU-Z the clock readings were always ZERO, i guess because a display adapter can't even have any clocks on it.
 
Mar 10, 2019
27
1
35
If the integrated GPU works, but not the PCIe GPU, I would have to wonder if perhaps it is a power supply problem. Much more power is required for the PCIe GPU. Having it stop booting? That makes the power supply more suspicious. Can it boot with the PCIe card removed? What is the PSU?
the PSU is a corsair CX450 2 months old, i doubt that is the problem. And no, it can't boot at all anymore, both the CPU and GPU fans turn but no light are lit and no video is displayed on the monitor.
 

LinuxDevice

Respectable
May 20, 2017
330
3
1,965
the PSU is a corsair CX450 2 months old, i doubt that is the problem. And no, it can't boot at all anymore, both the CPU and GPU fans turn but no light are lit and no video is displayed on the monitor.
What I'm suggesting is to remove the GPU temporarily as a test. Power requirements go down without this. I don't know if your particular setup requires more power or not, but the odds go up to near certain that more power is required if the removal of GPU results in boot. The design with switching power supplies means the system will refuse to boot if power never stabilizes (fans and lights don't have much meaning when the test is to see what happens under full load).
 
Mar 10, 2019
27
1
35
What I'm suggesting is to remove the GPU temporarily as a test. Power requirements go down without this. I don't know if your particular setup requires more power or not, but the odds go up to near certain that more power is required if the removal of GPU results in boot. The design with switching power supplies means the system will refuse to boot if power never stabilizes (fans and lights don't have much meaning when the test is to see what happens under full load).
Oh i see

Unfortunately i've already sent It to tech support as i deemed It beyond my capabilities, i'll come back with the diagnosis as soon as It comes.
 

ASK THE COMMUNITY

TRENDING THREADS