Question Windows on second monitor reset back to first monitor when monitors go to sleep - how to stop this?

Tyrlaan

Prominent
Apr 12, 2019
45
2
535
0
I guess the subject covers what I need help with. Running Win 10, not sure what other info would be helpful. Monitors are a ViewSonic VX2257 and HP 22uh.

Thanks in advance!
 

xenthia

Distinguished
Sep 20, 2012
175
16
18,595
4
I guess the subject covers what I need help with. Running Win 10, not sure what other info would be helpful. Monitors are a ViewSonic VX2257 and HP 22uh.

Thanks in advance!
How are the monitors connected to the device? directly on the hdmi port or using a converter? It seems that when the monitor goes to sleep it reports back to the computer that it doesn't exist anymore like it has been totally disconnected. Check its settings for such option.
 

Tyrlaan

Prominent
Apr 12, 2019
45
2
535
0
How are the monitors connected to the device? directly on the hdmi port or using a converter? It seems that when the monitor goes to sleep it reports back to the computer that it doesn't exist anymore like it has been totally disconnected. Check its settings for such option.
Hm....

One is displayport and the other is HDMI, both going into the same video card.

Are you referring to a setting on the monitor itself?
 

xenthia

Distinguished
Sep 20, 2012
175
16
18,595
4
Hm....

One is displayport and the other is HDMI, both going into the same video card.

Are you referring to a setting on the monitor itself?
Yes the monitor itself.

Also in Windows check your power options in the control panel, in the advanced power settings try checking your settings for your graphics cards and your displays.
 

Tyrlaan

Prominent
Apr 12, 2019
45
2
535
0
Yes the monitor itself.

Also in Windows check your power options in the control panel, in the advanced power settings try checking your settings for your graphics cards and your displays.
I can't seem to find power settings for the monitor other than the sleep setting in the control panel power options. I did however change my graphics card (nvidia) from optimal power to adaptive. Maybe that'll do the trick?

I suppose worst case scenario is to just stop the monitors from going to sleep.

UPDATE: Adaptive made no difference.
 
Last edited:

xenthia

Distinguished
Sep 20, 2012
175
16
18,595
4
I can't seem to find power settings for the monitor other than the sleep setting in the control panel power options. I did however change my graphics card (nvidia) from optimal power to adaptive. Maybe that'll do the trick?

I suppose worst case scenario is to just stop the monitors from going to sleep.

UPDATE: Adaptive made no difference.
Though extremely unlikely try changing the cable, you see in the VGA standard the monitors presence is detected using https://en.wikipedia.org/wiki/Display_Data_Channel https://electronics.stackexchange.com/questions/170546/how-does-a-pc-detect-a-vga-monitor if you check the wiring diagram of a VGA cable, in HDMI the same thing has to happen.
use a new hdmi wire and see if it helps with the situation.
 

Tyrlaan

Prominent
Apr 12, 2019
45
2
535
0
Though extremely unlikely try changing the cable, you see in the VGA standard the monitors presence is detected using https://en.wikipedia.org/wiki/Display_Data_Channel https://electronics.stackexchange.com/questions/170546/how-does-a-pc-detect-a-vga-monitor if you check the wiring diagram of a VGA cable, in HDMI the same thing has to happen.
use a new hdmi wire and see if it helps with the situation.
Okay, I'll give it a shot.

Interesting observation - when waking up from sleep, the hp22uh on HDMI is the one that wakes up first
 

Tyrlaan

Prominent
Apr 12, 2019
45
2
535
0
Solved!

Installed Win10 Powertoys. In FancyZones, there's an option to "keep windows in their zones when the screen resolution changes". Totally did the trick.
 

Tyrlaan

Prominent
Apr 12, 2019
45
2
535
0
Spoke too soon.

I've since found a tool called PersistentWindows that more or less fixes the issue., so I'm running with that.
 

ASK THE COMMUNITY

TRENDING THREADS