Windows set-up doesn't detect my SATA drives but BIOS does [Asus x-99a]

BodyCrasher

Honorable
Nov 19, 2013
20
0
10,510
0
Hello all. I have recently assembled a pc with these specs:
Asus x99a motherboard with i7 5930k
2x Samsung 850 pro 512gb ssd (Attempting to raid0)
1x WD Black 2TB 7200 rpm

My bios recognizes all 3 drives (and even the blu-ray drive). However, once we get to the Windows set-up page, it doesn't find any drive and we can't even install drivers (tried from a USB drive and even from the included motherboard support disk). I even managed to set-up the raid in the BIOS without any problem.

I've looked around threads a few and have tried to use the command prompt to:
select disk 1 (where my raid0 or even my regular 512gb ssd is identified as disk 1) and clean, but Windows set-up still doesn't recognize it...

Before we start,
1. Yes my SSDS are connected into the Intel SSD ports like the manual says
2. Yes I am using the original cables that came with the PSU / Motherboard
3. Yes the are properly plugged, otherwise they wouldn't be recognized in the bios.

My next guess is trying a different version of Windows... but even then I don't know if that would fix it, since I don't think it's the source of the problem.

Please help !!!
 
And what version of windows cant see it? Win7 and 8 should. Those 2 should let you select drivers, but you would have to get RAID drivers then extract them to the flash drive first.

XP wont (but I dont think you'll be installing this) unless you slipstream sata drivers

And what you using to install windows? The DVD? Flash drive?

Altho I wouldnt bother with RAID0. If one dies the other one will too
 

ASK THE COMMUNITY