Question Windows suddenly stopped detecting M.2 SSD

Fireflasher361

Distinguished
Sep 9, 2014
22
0
18,520
1
I’ve had this Intel 665p M.2 NVME SSD installed for around 2 years now. Had no problems installing it and setting it up. Ran flawlessly since then. Windows isnt installed on this drive, I use it as an additional drive strictly for games. Recently however I turned on my pc and found that windows was no longer detecting the M.2 drive. It wasn’t showing up in “This PC” in windows explorer or under disk management. Strangely, it does show up in BIOS, just nowhere to be found in windows. I tried updating my BIOS after I noticed this problem, didn’t fix it. I also updated the Intel NVME driver it uses, didn’t fix it either. I’m not entirely sure what could have caused it. The only thing it may be related to is the fact that I updated most drivers in my PC on the day prior to this problem showing up. I’ve also been juggling around different RGB programs trying to find one that works for most of my RGB devices. Any suggestions would be appreciated.


Motherboard: ASUS x570 TUF Gaming Plus WIFI
M.2 Drive: Intel 665p
OS: Windows 10
 
Last edited:

Fireflasher361

Distinguished
Sep 9, 2014
22
0
18,520
1
Please show screenshots from
Disk Management,​
Device Manager - Disk drives and Storage controllers sections expanded and​
Windows Storage Spaces.​
(upload to imgur.com and post link)
View: https://imgur.com/a/X6L2Qcs


I haven't setup storage spaces but I included what it looks like anyway. I also provided some additional screenshots related to the device manager section. Apparently the m.2 drive shows up in device manager? and I noticed there's an exclamation point sign on the icon so I included screenshots of the relevant info when checking properties.
 

ASK THE COMMUNITY