Windows update not working

ggbyteffex

Reputable
Feb 15, 2014
8
0
4,510
0
This is driving me mad, I have tried various answers online all without success. Even Microsoft "Run this" fix doesn't find any issues.
I've run "services.msc" and under status it doesn't have anything, when I try to "start" the service I get;
"Windows could not start the Windows Update service on Local Computer"
"Error 2: The system cannot find the file specified"
What is this?
Please help??
 

ggbyteffex

Reputable
Feb 15, 2014
8
0
4,510
0

Rav, as I said in my post, I have tried this and it does not resolve the problem.
 

ggbyteffex

Reputable
Feb 15, 2014
8
0
4,510
0

Thanks for the thought, but all I get after logging in is that I there will be a charge for the support, very disappointing when there is obviously known issues with Windows Update not working
 

ggbyteffex

Reputable
Feb 15, 2014
8
0
4,510
0


Ravi, my apologies at misspelling your name. I will follow up on the supplied information and let you know of the outcome.
 

ggbyteffex

Reputable
Feb 15, 2014
8
0
4,510
0
Still no luck with getting Windows Update to run, I have downloaded and am currently running "Microsoft Windows Malicious Software Removal Tool - Feb 2014" its been running for 23 hours now and so far hasn't found any infected files.
I'm convinced there is an easy fix that I just haven't worked out or found yet!
Disappointing that each time I go through Microsoft site it just refers me to start "Windows Update" which of course I can't get running.
I downloaded the Microsoft Update Standalone Package but when I run it I get (Error....) and no further action.
My next action will have to be a "recover" install, I guess. Only trouble is that other than this issue of updates not running, everything else on the computer is running well and coming up as clean of malware.

After nearly 28 hours of running the above tool, "No infected" files were found, Oh well! I'll keep trying to find the problem.
 

ggbyteffex

Reputable
Feb 15, 2014
8
0
4,510
0

aldan, thanks for your suggestion I have been sorting through that and trying "fixes" all without success so far. I will feedback, to this forum, any outcome if successful

Update:
Via Microsoft Community, I have downloaded and run the "Windows Update Troubleshooter", with the following results;
Problems found
Windows Update error 0x80080005(2014-02-18-T-03_19_05P) Not fixed X
Problems installing recent updates Not fixed X
Check for missing or corrupt files Detected !
Some security settings are missing or have been changed Fixed /
Service registration is missing or corrupt Fixed /

What next, I'll keep trying to find a solution.
 

Ravi Gagan

Honorable
Feb 6, 2014
735
0
11,360
197
If that don't work out either then
a) Click on “Start” and type “cmd” (without the quotations).
b) When you see the “cmd” icon,Right Click on it and select “Run as administrator”.
c) On the open Command Prompt window copy and paste the commands (all at once) –
Note: To paste, right click on the title bar of the command prompt window andselect Edit, Paste.
net stop wuauserv
net stop cryptSvc
net stop bits
net stop msiserver
ren C:\Windows\SoftwareDistribution SoftwareDistribution.old
ren C:\Windows\System32\catroot2 catroot2.oldnet
start wuauservnet
start cryptSvcnet
start bitsnet
start msiserver
pause
d) Wait for the process to complete.
e) Close the Command Prompt by pressing Enter, spacebar, then type"exit" (without the quotations) and press enter.Now, run windows update again. It will take longer to rebuild the database.

Be patient.
 

ggbyteffex

Reputable
Feb 15, 2014
8
0
4,510
0
To Ravi Gagan and to aldan, a big THANK YOU both.
I had tried several of the suggestions offered here without success including some of Microsoft automatic "fixes" today I took a little longer to read through a variety of answers in Microsoft Community and got onto the following suggestion <<http://www.bleepingcomputer.com/download/windows-repair-all-in-one/>> from someone there. After downloading and running this, my system is back running WU's. Hooray!!
 

Ravi Gagan

Honorable
Feb 6, 2014
735
0
11,360
197



Congrats!
It was a really nasty problem
I hoped above methods could help you because many were facing same problem and they resolved it by the methods i posted
 

ASK THE COMMUNITY

TRENDING THREADS