Windows Update site says SP2, but System properties say SP1

Warpspasm

Distinguished
May 28, 2003
359
0
18,780
I've been putting off upgrading to SP2 for a long time, but last night I decided to wipe my drive clean and redo the OS. I figured it was also a good time to update Windows XP to SP2. I went to the Update site and looked at the auto updates etc, visited the SP2 specific page and said to do the update. I was doing so many things at once (trying to get my clean drive populated) I really don't remember the system doing much of an update. In fact, I don't remember it doing the SP2 update at all. After fooling around with installing some other programs, I went back to the update site and was going to do it for real. The SP2 page said Iwas running SP2. I thought, "huh. . . I don't remember it actually doing the update", so I looked at my system properties. It still says that I'm running SP1. I rebooted, went back to the Windows update page and again is says I'm running SP2. Did the system properties again, and it still says SP1. Why the heck the descrepancy?

How the heck do I figure out if SP2 is on there? If it isn't, how to I get it there when the Windows update page says it's already installed?
 

sturm

Splendid
do you have the firewall selection that SP2 installs? If not then you dont have it.
Look in the add/remove programs and see if its listed. SP2 takes about 30 minutes or so to install off a cd, longer if your downloading it. If you can get a cd try using it. If all else fails you, and you dont have many other programs installed, I would just start over again.
 

Warpspasm

Distinguished
May 28, 2003
359
0
18,780
I don't know why the update was saying that SP2 was on the PC, because it wasn't. Once I installed ALL of the available updates for SP1 it then allowed me to do SP2. Weird.