Windows Vista and SATA/RAID Controller 82801 GR/GH


Jul 7, 2006
On my computer, when I run the Vista Upgrade Advisor, it says that the Intel SATA/SCSI//RAID controller driver may not exist for Windows Vista.

Does this mean when I install Vista (beta 2), I will lose the RAID functionality?

Will I lose the RAID and SATA on my hard disks? Will they even work without SATA/RAID?

Thanks in advance.

BTW, my RAID controller is:

Intel 82801 GR/GH

Also, this conroller is listed as supported hardware on this website:

Can this website be trusted? I want to be sure before I install. Does anyone else use this chipset and have Vista working
Yeah, and it also says that Logitech Quickcams are supported in 64-bit... which they are not.

If you have a RAID setup, I wouldn't attempt to install Vista without verifying that the drivers will actually work. I can't see Vista not having chipset drivers for Intel... but the RAID functionality may be questionable.


Sep 16, 2006
Hi, I have a question that is somewhat related. THG showed us how to "hack" Windows XP so that it can do RAID-5 in software. I went ahead and did this, so now I'm happily using 4 x SATA disks in software RAID-5 on XP.

What happens when I install Windows Vista? I've tried it (separate boot partition) and there doesn't seem to be any built-in way to configure RAID-5 in Vista. Any word about fixing this, or should I either remain on XP or abandon the software RAID?

It appears I can answer my own question:
I had of course already installed the driver for my SATA adapter, and when I did so, it found my 4 drives, but they were not mounted.
Then I went into Vista's "Computer Management" (damn hard to find via the "easy" control panel, but in classic view it's right there uner Administrative Tools). In Computer Management, open the Storage / Disk Management module and there were the four disks - they were disabled.
Right-click one, and select "Import foreign disks" - they were now mounted but invalid. For good measure a reboot, though I was not prompted to do so.
Then back into Disk Management - they are now "failed". Right-click, "Reactivate". Hmm, afterwards they're still "failed", but perhaps a reboot (with chkdsk) will fix it?

Still "failed" and refusing to "reactivate" properly. I better leave this alone and go back to my XP boot partition instead. I don't want to mess too much with this RAID right now.