Windows wants to turn Aero theme off!?


Dec 26, 2012
Hi all, im new here but ive been having a bit of trouble. Just got a new GTX 660ti msi power edition for Christmas and I put it onto my HP desktop. My computer has a FX-8150 8-core processor. But whenever I play WoW windows comes up with this "Your computer is running slowly, turn off aero theme to help preformance". But its running fine I dont notice anything!! I have OC'd it with the MSI afterburner to this -> +70 core clock, +400 memory clock and I maxed out the power limit. I am using two monitors but one is a VGA and the other is a HDMI.

Here is my specs:

Except my graphics card is upgraded and my PSU to 520w. Nvidia GTX 660ti MSI Power Edition.
Please help. Thanks in advance.


Apr 15, 2012

For that mix of hardware (don't forget the 8-core CPU, and overclocking) the minimum recommended power supply is 580-650W...and that's assuming a really good name brand of power supply.

A good quality power supply of 520W might be barely adequate (read: INadequate) for your rig if you were running a quad-core CPU and not overclocking at all. That would be closer to an "average" system that the PSU requirements are based on. For an average system, your video card requires 500W. For an extra 4 cores in the CPU, as well as overclocking?
I wouldn't personally feel comfortable running that rig on anything of less quality or power output than something comparable to a Corsair GS-700 or similar.

I don't know if you've got a power starvation issue. BUT, you do have a power starvation SYMPTOM. And, on paper at least...your power supply is undersized. By at least 200W.


Nov 7, 2012
I would say that Windows 7 has a bug that causes it to think your Aero theme isn't performing up to standards even when your equipment can kick its butt.
You said your computer is always performing fine even when it displays this message. Same for me.

Take this for example.

I know most people don't put much into the Windows Experience Index, But since windows does use it to judge your computer performance, Its useful.

I have a 7.9 - 7.9 in Both Desktop and 3D Gaming Graphics (GTX 660), But Windows STILL tells me to disable Windows Aero after playing certain games. Not all the time though. I went through Event Viewer and narrowed this issue down to Event ID 500 and 501. I have Searched the NET for about the last year off and on looking for a fix to this issue. I have loaded up with a COMPLETLY clean setup and still the issue will display itself from time to time..

Honestly its not that often. It only displays maybe once a week.

The only thing Ive found is it to disable transparency in your display settings.
Ive seen people try all the options suggested to you but none of them have ever stopped the issue from all the articles and forums ive read.

Since its not a MAJOR issue from my experience, I wouldn't worry about it personally. I like Aero and refuse to disable it lol
All my friends have W7 and have the same issue, which is why, in the end, I think its a W7 issue