[SOLVED] Windows won't boot after DC power jack replacement

Cambreaker

Distinguished
Mar 3, 2012
10
0
18,520
1
Working on my mother's Dell Latitude E6400 running Windows 7.

I just replaced the DC Power jack by following a detailed, step-by-step video, and everything seemed to be correctly reassembled. The process involved basically stripping the machine down to the chassis to get at the track where the internal wires run from the jack to the MB. No other hardware was replaced, no externals are attached.The power connection is solid and the battery has charged to 100% (visible in BIOS). Windows fails to boot (though I DO get past the POST page into the first few frames of the loading animation). Safe Mode also fails (Watching the safe mode boot attempt on screen shows the crash happening at /CLASSPNP.SYS). Startup repair fails, with these details:

Disabling automatic restart on boot failure yields the following BSOD codes:
STOP: 0x0000007B (0xFFFFF880009A8E8, 0xFFFFFFFFC0000034, 0x0000000000000000, 0x0000000000000000)

Problem signature
Startup repair offline
1 - 6.1.7600.16385
2 - 6.1.7600.16385
3 - unknown
4 - 21199926
5 - AutoFailover
6 - 9
7 - NoRootCause

I have tried the following in Startup Repair's Command prompt, all of which report no error/failure except the last:
-chkdsk C: /f /r
-sfc /scannow /offbootdir=c:\ /offwindir=c:\windows
-bootrec /fixboot
-bootrec /fixmbr
-Bootrec /RebuildBcd (this found no OS)

I have run the following diagnostics or attempted fixes not in command prompt:
-Start using last known good config
-system restore to date before jack replacement
-Memory diagnostic
and probably some others I'm forgetting.

Things I have NOT tried:
-Bcdedit /export C:\BCD_Backup
ren c:\boot\bcd bcd.old
Bootrec /rebuildbcd

Most sources for the above recommend it for Bootmgr is missing errors, which I have not seen here.

"NoRootCause". Hilarious. :mad:
Lol hlep?

edit: So, I just realized this posted to Laptop tech support, but I thought I'd posted it to Windows 7. I leave it to mods' judgment if this is the appropriate section.
 
Last edited:

Cambreaker

Distinguished
Mar 3, 2012
10
0
18,520
1
FIXED! The problem was that the CMOS battery had been unhooked in order to extract the jack, and CMOS lost settings. The machine's CMOS had defaulted the SATA operate in IRRC mode, and needed to be in AHCI mode. For any who encounter this post from google, hit F2 to get into your CMOS, find "SATA Operation", change it to AHCI (you'll get a warning about it causing your system not to boot if it's wrong, click OK), and away you go.

I should note the answer came from me calling into parts-people.com, from whom I purchased the replacement jack. +1 million points to them!
 

ASK THE COMMUNITY

TRENDING THREADS