[SOLVED] Windows XP not seeinvg more than 2.89gb ram

Hello i currently have a laptop with 12gb ddr3 running windows XP 32 bit with all updates. When i go into properties i only see 2.89gb of ram. I know 12gb ram doesnt work with 32 bit os, but why is only 2.89gb available?i though i was limited to 3.5gb with 32bit xp.
 
I cant change that vram amount in Bios, but ill just enable page file and forget about it. Windows xp is quite lightweight, so i shouldnt run into much issues. If i do, the ssd page file cant be bad. I have heard of making a ram disk as page file, bacically adding ram.
 
Also another question about graphics. I could set the right resolution, but there was some major glitching when moving programs around. When i installed the latest graphics driver to support xp, this went away. The problem is with youtube. I have installed the latest version of uc browser for xp (based on newer chrome but xp compatable) and youtube has problems at every res. If i set it at 1080p or 144p it will play fine for a second then lag and have some screen tearing. It cant play any youtube smoothly. What gives?
 
Last edited:
No i want windows xp for the older games. This is just a spare computer and i have a modern windows 10 computer for games, but it wont run xp even on 2nd partition since it has an amd ryzen cpu and unsopported gpu. I actually took the windows 10 hdd out (had been upgraded from windows 8.0), replaced it with an ssd and put windows xp on it. I have gone through the inside and out of the bios and there isnt that setting for vram changing. Chrome and firefox dont support xp, but uc browser does since its based on an older version of chrome, but it is otherwise up to date. The firefox installer always fails to open aswell. When i use google.com a message pops up and says to update chrome, so thats how i figured that out. I would really like to to fix the graphical issues.
 
Last edited:

mgallo848

Commendable
Apr 4, 2018
1,551
34
1,790
132
I figured that's what you were doing but I wasn't sure. I currently have a Core 2 Quad QX9560, 4 gb ddr3 (blah, blah,blah) running Windows XP for a family member that has a VCR that plugs directly into the PC to archive family photos (the software ONLY works with XP)

I do have Firefox installed on it. It was a PITA to find the installer on their site but it's there. They do still support XP. If I didn't delete the installer and you're interested, let me know and I'll post a link to download FF.

Edit: Found it http://www.mozilla.org/en-US/firefox/all/?q=English (US)
 
Thanks for the info, I think the installer I had may have been 64 bit by accident since I downloaded it on my main win 10 pc (link below) and used a USB drive to put it on the laptop. I chose the 32bit windows version from that link and copied it to the laptop. It doesn't open. When I click on it, my CPU usage goes up from 0% idle to about 30% and i see an hourglass, but no processes show in task manager and nothing opens at all.
 
Last edited:
Ok, I figured it out. I went to all releases and downloaded the last 32-bit version for win XP and the installer works great. Firefox installed, the pc BSOD, but after a restart, everything seems fine. 1080p youtube in firefox works flawlessly, so I will use Mozilla 52.9 on this laptop. It still feels similar to the latest firefox version.
 
Last edited:
Quick (hopefully) question. I have a CD of NFS SE2 i bought long ago and would like to play it on this pc. I remember i actually made it work on vista long ago, so i dont see why it wont work on XP even though its a windows 98 era game. I tried windows 95,98, and 200 compatability modes and the game doesn't start at all. It installed fine but wont open. Selecting 256 colors, 480p, and no visual themes makes the pc blackscreen and then go back to desktop. Running as admin causes a black screen and then a "NFS SE2 encountered a problem and needs to close" message.
 
Figured it out. I didnt bother to think that a game from 97 wont work with direct x. Im using nglide to emulate the glide api and the game opens and runs. The problem now is the game runs like utter poop. It is at maximum 5 frames per second and changing gfx settings changes nothing at all. I cant play the game like this, so how can i fix this? Do i need to patch the game? The igpu is way more powerfull than a vodoo or something.
 

Similar threads


ASK THE COMMUNITY