Windows XP SP3 - Connected to wifi, no internet

Sep 24, 2018
7
0
10
0
Hi all,

I’m resurrecting an old S478 beast to reminisce with some games from yesteryear. It has a TP-Link PCI wifi card that successfully connects to my WiFi network (via Virginmedia superhub3), but it won’t access the internet/load a webpage.

I have the same issue with a Windows ME machine. My smartphones, MacBooks and Windows 10 desktop can all access the internet just fine.

Via CMD prompt I’ve tried an IP Config reset and DNS flush, but no joy.

Any ideas? Thanks in advance.

Dan
 

ex_bubblehead

Glorious
Moderator
Not surprising that XP won't load any web pages. Any browser that would run on XP is LONG out of date with regards to protocols now in use. And, with the cessation of updates several years ago XP is just a security hole looking for a place to happen. If you are insisting on running XP then disconnect it from all networks and run it stand alone.
 
open up a command prompt and enter the command..... ipconfig<space bar>/all

for a successful connection you need something along the lines of

IPv4 Address : 192.168.1.10
Subnet : 255.255.255.0
Gateway : 192.168.1.1 <- SH3 address
DNS : 192.168.1.1 <- SH3 address

if ok, back command prompt, enter command.... ping<space bar>google.com

if it gets to the outside world, you will get 4 replies.

if it doesn't, could be the wifi card

Although not recommended, XP can still be used on internet, plenty of companies still do.

If you want to play old games, have you though of using Virtialbox to run XP, plays them well if not too graphic intensive and uses the hosts network connection.
 
Mar 30, 2019
1
0
10
0
Hi, I have a similar issue.

HP 2530p
Windows XP SP3

Laptop required with XP for a specific job with no sensitive data so not worried about security.

Drivers for ethernet and wifi had to be installed manually, but all seem to work now in device manager etc.

Tried the above, I get:

Connection-specific DNS Suffix: default (is this normal?)
IP Address: 192.198.1.51
Subnet Mask: 255.255.255.0
Default Gateway: 192.198.1.1

I've also run the following:
netsh int ip reset reset.log
netsh winsock reset catalog

Also been through all the internet options and reset settings to default.

LAN settings in internet option all look correct (selected to automatically connect).

I get four responses from the ping. All very promising.

Tried running in safemode.

Running internet diagnostic says it might be a firewall issue. No other suggestions from it. I would have thought the ping wouldn't work if it was a firewall issue.
I have no third party antivirus or fireall installed, and I've tried disabling the windows firewall (it's a clean install).

Still no internet.

Anything else I can try?
Thanks

UPDATE:
I've installed a portable version of firefox and I can get on the internet using that.
IE, and driver updates and any other system internet connection still doesn't work.
So confused.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS