Wired and Wireless network Conflict

Kola Hall

Honorable
Jan 30, 2014
12
0
10,510
0
Hi all,

I have a small office with Ten computers. All connected to each other via 10/100 network switch with RJ 45 cable. Network is running smooth; file sharing working.

Out of these 10 computers my partner and I have an additional wifi adapter for internet access on our machines which we don't share with anybody. Up until recently everything was running smooth. Our internet was running via wifi and at the same time we were able to do file sharing with rest of the computers through the physical Ethernet network.

Suddenly one of these days our internet stopped working. My partner and I were able to connect to the wifi without any errors but when trying to open a page it would give us a page cannot be displayed after a long wait. So I went to the command prompt and pinged www.facebook.com and to my surprise it gave me: reply from 192.168.137.1 (this happens to be the default gateway of the ethernet adapter local area connection) : destination net unreachable. I immediately removed the ethernet cable from the back of my computer and tried connecting to random pages and it connected in no time. Same for my partner too. So for the past few days we've been working like this plugging and unplugging the network cable and it's frustrating.

We have no idea what we did for such a change to take place. Why is our computer trying to connect to the internet through the ethernet connection all of a sudden? How do we fix this? All computers are Windows 7 Ultimate.

Thanks in advance.
 

silentplanner

Honorable
Oct 28, 2013
581
0
11,160
92
It would be better to understand if you provide a network map, however it seems on finding both Ethernet and Wireless connections system is routing internet traffic to Ethernet if you want to re rout internet traffic through wireless adapter follow these steps for (Windows)

1. Click the Start Button
2. Right Click "Network" and then left Click Properties
3. From the "Network And Sharing Center" window click "Change Adapter Settings"
4. On the "Network Connections" window, press the ALT + F key on your keyboard to being up the menu bar
5. Click the "Advanced" menu and then "Advanced Settings"
6. In the "Advanced Settings" window you will see the "Adapters and Bindings" tab and under "Connections" you will see the order they are in, you can use the arrows to the side to move the connection priority up and down.


 
It is surprising it used to work before. You are only allowed to have 1 default network/gateway. When there are multiple it will pick the one it feels is best which generally is the ethernet.

There are a number of ways to solve this but the simplest is to only have a single default network. On your ethernet adapter tcpip settings you need to change the default gateway to blank.
 

Kola Hall

Honorable
Jan 30, 2014
12
0
10,510
0


Thanks a lot for your response. I followed your steps but looks like everything was in that order already, despite which it chooses the ethernet connection for internet. Here are some screenshots:





Please help me out buddy. Thanks in advance.
 

Kola Hall

Honorable
Jan 30, 2014
12
0
10,510
0


Hey, Thanks for you reply. When I got to the TCPIP settings the default gateway is already blank :??: Check this out:



Thanks in advance.
 
It is using DHCP which means it learns it from a router on that network. The simplest way is to fill in a static ip address and mask and leave the gateway blank.

There is someway to set the metric on the ethernet adapter so it is higher (lower is better) than the wireless but it tends to be simpler to just set a static ip address.
 

Kola Hall

Honorable
Jan 30, 2014
12
0
10,510
0


I've got no idea how to do what you are suggesting here. I don't have any idea about networking. It'll be really nice and appreciated if you could spoon feed me here. Thanks in advance.
 

silentplanner

Honorable
Oct 28, 2013
581
0
11,160
92
go to start in run type cmd there type command ipconfig attach the screenshot of ips so i can help you further.
Note: Screenshot should contain both adapters information or simply just type there ips.
 

Kola Hall

Honorable
Jan 30, 2014
12
0
10,510
0

I went to the Wireless adapter properties and filled in a static IP and subnet mask. It didn't work, showed unidentified network. Then I went to properties again and changed it back to 'obtain IP address automatically' and it started working. But that was only momentary. After we tried on both the computers it worked for a while and then it was back to being the same.
 

Kola Hall

Honorable
Jan 30, 2014
12
0
10,510
0


There you go

 

silentplanner

Honorable
Oct 28, 2013
581
0
11,160
92


go to wireless adapter ip configuration there assgin manual static
ip 192.168.0.140
subnet mask 255.255.255.0
Default Gateway 192.168.0.1
apply and check internet
 

Kola Hall

Honorable
Jan 30, 2014
12
0
10,510
0


You the man! Thanks a lot. This works.
 

Kola Hall

Honorable
Jan 30, 2014
12
0
10,510
0
Hey Silentplanner, thanks a lot for your effort and I'm sure your method works too. It's just that I tried Bill's suggestion before and that worked for me. Thanks again man. Really appreciate your help too.
 

Similar threads


ASK THE COMMUNITY