Question Wired Ethernet connection to Desktop is slow.

Oct 7, 2019
2
0
10
0
So I currently pay for 300Mbps for my internet. I use a modem/router payed through by my cable/internet provider and a Cat5e cable to connect my modem directly to my desktop.

I have tested my speeds with a secondary laptop, using the same exact cable and was able to achieve 300Mbps speeds on it so the cable itself is working properly.

There is something bottle-necking my internet speeds within my desktop itself and it's driving me nuts trying to figure out what's wrong. For whatever reason my desktop will cap out around 100Mbps.

My drivers are up to date on my NIC, I have turned off Large Send Offloads, The speed & duplex rate it set to 1.0 Gbps Full Duplex. I tried using different DNS servers (which doesn't really make a difference). Auto-Tuning has been turned off. I disabled IPv6. All unnecessary background apps are disabled. I uninstealled any unused programs to clear up disk space and de-cluttered.

I am kind of at a loss, I'm not sure if it's due to some kind of service running or a program that's killing my speeds. I know for a fact that ROG GameFirst II messes with my internet speeds but as soon as I kill the program in task manager it shoots back up. It will instead make my speeds in the 40's. Then once stopped it will go back up into the 100's again.

Anyone else having these issues? It seemed to start 3 Windows updates ago, and since then has been a pain in the butt to try and troubleshoot. Thanks for any help in advanced.

Motherboard: ROG MAXIMUS VIII HERO ( Intel® Ethernet (i-219V )
OS: Windows 10 Home Edition 64-bit
 
You need to leave the setting on the nic on auto. It will always get the best possible speed. You can not just set one end you must set the router also. Most routers do not have that option. When you set just one end it confuses the negotiation and many times it will drop to 100m half duplex.

You want to uninstall the gamer crap software. It is a fake thing since it can only affect traffic inside the machine and almost all issues are some place farther into the network where it can have no effect.

If you do this and still get nowhere I would try a new cable. Make sure it is cat5e (you can buy cat6 if it is cheaper). Be sure the cable is pure copper and has wire size 22-24. No flat or thin cable and especially no CCA cable.

Cables are very strange when they go bad. It would be nice if they just completely failed. They can work on some machines but not others. Other will work well and randomly drop to lower speeds. A end only has to have 1 wire that is just slightly not making proper contact and it does all kind of strange stuff.
 
Last edited:
Oct 7, 2019
2
0
10
0
Set all settings on the NIC back to default, Uninstalled the Gaming Software, and tried 3 different cables, all Cat5e. Each cable worked at getting the 300Mb speed on my laptop but none worked for the desktop. I'm still only getting the 100Mbps speeds.
 
There are really only 3 things that can cause this. It is a bad cable, a bad port in the router and a bad port in the PC.

The speed negotiation is actually a fairly simplistic function done in very low level hardware so there are seldom driver issues. You of course could manually set it to 100mbps but there is not much other than that you can do to affect this. You could boot a linux image off a USB stick which would eliminate anything related to software.

It almost is always a cable but you could have physical damage to the port in your pc which of course you can't fix.

Some nic cards are really picky about cables and no home user can afford the meters to test cables to see if they still pass certification tests.
 

ASK THE COMMUNITY

TRENDING THREADS