• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Wireless for Internet, LAN for NAS...Help?!

Forgotten031511

Honorable
Jun 1, 2015
998
1
11,365
165
Okay all this makes little to no sense to me, and I am SURE there is an easy fix but I cannot find it.

Here's the deal. I just moved to a new house, so the networking options are limited. Therefore, I have my Modem and Wireless Router (from the ISP) down stairs in the living room (no bonded DSL lines go to my second floor) and my office is up stairs. I have USB Wireless Adapters on my PC's for internet. BUT when I also connect my Router (WiFi and WAN Disabled) with NAS Drives via Ethernet, my PC thinks it should use the Ethernet for Internet and not the USB Wireless Adapters.

How can I use the Wireless for Internet and the Ethernet for LAN to a Router with NAS Drives?

Win 10, latest build
 

Ralston18

Titan
Moderator
Make and model information for modem and router(s)?

Connectivity being:

ISP ----DSL----> splitter/filter----> Modem ---> [WAN] Router [LAN] -- ethernet ---> NAS and ~Wireless> Your PC.

Not sure about the second router...

Edit and correct my line diagram as necessary.

There should only be one router providing DHCP IP addresses.
 

Forgotten031511

Honorable
Jun 1, 2015
998
1
11,365
165
ISP > DSL > Spliter/Filter > Modem > Wireless Network > Wireless Adapter > PC < Ethernet Connect < Router< NAS Drives

Basically I need the PC to use Wireless at Default Internet Connection. The other Router with NAS Drives never even touch the internet, just a LAN network as I need the Router to Connect BOTH my WD Cloud Mirror Drives (NAS) to my PC's
 
If you're using the same subnet on both your wired and wireless networks, windows will get confuse. If you can change the subnet on the wired router to 10.x.x.x then you shouldn't have any problems as long as your default gateway is for the wireless. You will probably need to use the route command to manually fix this.
 

Forgotten031511

Honorable
Jun 1, 2015
998
1
11,365
165
If you're using the same subnet on both your wired and wireless networks, windows will get confuse. If you can change the subnet on the wired router to 10.x.x.x then you shouldn't have any problems as long as your default gateway is for the wireless. You will probably need to use the route command to manually fix this.
Not sure I fully know how to do that off hand, is there a Tutorial or Step-by-Step I could follow online somewhere? I am familiar with all this, just haven't been in the field professionally for over a decade, so I'm a bit behind lol

Wireless Internet Source: ZyXEL VMG4825-B10A
NAS Router: ASUS RT-AC78U
 

RealBeast

Titan
Moderator
I will assume that you have precisely followed the instructions on the method that you posted.

Have you tried going into the W10 PC network control panel, select change adapter settings, click on advanced in the menu bar (you may need to hit alt to see it), then select advanced settings. In the adapter and bindings tab, place the wireless network above the Ethernet in priority.
 
Not sure I fully know how to do that off hand, is there a Tutorial or Step-by-Step I could follow online somewhere? I am familiar with all this, just haven't been in the field professionally for over a decade, so I'm a bit behind lol

Wireless Internet Source: ZyXEL VMG4825-B10A
NAS Router: ASUS RT-AC78U
Actually looking at the image, it's really simple. Set your wireless IP to dhcp like normal--don't change anything there.

Log into your asus and change the default IP address and subnet to something in the 10.x.x.x range, like 10.10.10.1 for the gateway. Set the dhcp range for just 5 devices (or however many devices you have wired). Then set up a static IP for your wire connection in the range of the subnet, but outside of the dhcp range, like 10.10.10.10. Leave the default gateway blank. This should work!
 

Forgotten031511

Honorable
Jun 1, 2015
998
1
11,365
165
Actually looking at the image, it's really simple. Set your wireless IP to dhcp like normal--don't change anything there.

Log into your asus and change the default IP address and subnet to something in the 10.x.x.x range, like 10.10.10.1 for the gateway. Set the dhcp range for just 5 devices (or however many devices you have wired). Then set up a static IP for your wire connection in the range of the subnet, but outside of the dhcp range, like 10.10.10.10. Leave the default gateway blank. This should work!
Thank you for helping walk me through this. I am logged into my ASUS Router and when I try to change the LAN Subnet Mask to 10.10.10.1 it says it is not a Valid IP.

However, I do see the option to manually configure the DHCP Server on the ASUS Router. If I disable that, and manually assign Static IP's to each NAS (outside of the Subnet Range) it should work...am I understanding this correctly?
 
Thank you for helping walk me through this. I am logged into my ASUS Router and when I try to change the LAN Subnet Mask to 10.10.10.1 it says it is not a Valid IP.

However, I do see the option to manually configure the DHCP Server on the ASUS Router. If I disable that, and manually assign Static IP's to each NAS (outside of the Subnet Range) it should work...am I understanding this correctly?
I forgot that most consumer router don't like the 10.x.x.x subnet. You can set it to something like 192.168.10.1 and it should work the same way.

Your nas and other devices would still get their IPs via dhcp. It is your computer that you would set up manually with an IP outside the asus dhcp range, but still inside the subnet (if your mask is 255.255.255.0, then it can be anything up to 192.168.10.254). Be sure to make sure you DON'T have a default gateway for the wired. That's the key.

You can test all your connections using ping. Ping google, ping your nas and both should work. :)
 

Forgotten031511

Honorable
Jun 1, 2015
998
1
11,365
165
Appears I am trying to change those setting in the wrong area, or something. 192.168.10.1 did not work either stating it is not a valid IP.

I am in the LAN Settings of the Router, didn't see anything under Administration or other tabs. Suggestions?

Maybe just play dumb and ask my ISP lol
 

Forgotten031511

Honorable
Jun 1, 2015
998
1
11,365
165
Okay, help...still cannot get my LAN NAS to work with the WiFi Internet. Here is my ipconfig. What do I need to change on the top connection (192.168.10.102 - Static Assigned) as that is my LAN to a router with no internet and WAN Disabled for my Local NAS Drives.

(192.168.1.249 - DHCP) is my USB WiFi to my ISP's rented router (until I can run proper cabling)

 

USAFRet

Titan
Moderator
Mar 16, 2013
126,030
4,404
159,940
19,750
Why aren't both things just connected to the router?
NAS via ethernet, PC via ethernet or WiFi?

The PC talks to the NAS, through the router.
From any of my devices, both wired and WiFi, I can talk to the NAS box which is connected to the router.
 

Forgotten031511

Honorable
Jun 1, 2015
998
1
11,365
165
Why aren't both things just connected to the router?
NAS via ethernet, PC via ethernet or WiFi?

The PC talks to the NAS, through the router.
From any of my devices, both wired and WiFi, I can talk to the NAS box which is connected to the router.
Trust me, if I could I would...right now we just moved and the house is not wired properly for networking. So to get things rolling so I can work, I have the leased ISP Modem/Router downstairs and my Office/Workstations upstairs on my personal router and NAS.

Overall, I need to change the IP Range and Static IP for my PC's to my Office Router and a different Subnet so my computers know which network connection has internet.
 
Okay, help...still cannot get my LAN NAS to work with the WiFi Internet. Here is my ipconfig. What do I need to change on the top connection (192.168.10.102 - Static Assigned) as that is my LAN to a router with no internet and WAN Disabled for my Local NAS Drives.

(192.168.1.249 - DHCP) is my USB WiFi to my ISP's rented router (until I can run proper cabling)

Remove the default gateway for the static address of 192.168.10.102. This should allow your pc to use internet via wireless, and access the nas and other stuff through the wired.
 

ASK THE COMMUNITY

TRENDING THREADS