[SOLVED] Wireless networks of neighbors unable to be stopped from appearing in my PC.

Enthir

Reputable
Oct 29, 2016
6
0
4,510
0
I tried running the following Command Prompt as Administrator:
netsh wlan add filter permission=block ssid="WIFI NAME" networktype=infrastructure
(replacing the WIFI NAME with the neighbour's Network Name.)
It appears despite this. And when I try to run once again, the Prompt says
This filter already exists in the same list on the system.

How can I stop the appearance of the neighbours' networks? Please guide me.
 

Ralston18

Titan
Moderator
Update:

Did you use quotes around the network name you wish to filter out?

I checked the command format and it appears that quotes are not needed.

Reference:

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc755301(v=ws.10)?redirectedfrom=MSDN#bkmk_wlanAddFilter

Did you try the command in Powershell? With and without quotes....

UPDATE:

I was able to test the filter permission command via Powershell (Admin) on my wireless all-in-one computer. Command worked well - did not use/require quotes around the targeted SSID.

Eliminated 2 of about 15+ wireless networks around my house. So far the two networks have not reappeared.
 
Last edited:
Not sure your issue. This is like putting on a blindfold and then saying the sun does not exist.

Just because your computer does not show it does not mean that the signals are not still coming into your house. Your computer should never do anything with it since it is likely encrypted and windows will only automatically connect to open systems. It doesn't even do that by default there is a option that only allows it to connect to networks you have manually connected to.
 

Ralston18

Titan
Moderator
Interesting:

Does blocking initially work and then "fails" after your reboot your computer?

First verify that your netsh command is formatted correctly.

https://answers.microsoft.com/en-us/windows/forum/all/how-to-block-unknown-wi-fi-network-from-appearing/027345e8-899e-413c-957b-0279a866c5d6

Appears to be but a closer check is warranted.

Second:

use show networks to verify the wireless network names and ensure that there is not a typo in your use of the network name you are trying to block.

use show filters to display the allowed and blocked networks listing

use show blockednetworks
 

Ralston18

Titan
Moderator
Update:

Did you use quotes around the network name you wish to filter out?

I checked the command format and it appears that quotes are not needed.

Reference:

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc755301(v=ws.10)?redirectedfrom=MSDN#bkmk_wlanAddFilter

Did you try the command in Powershell? With and without quotes....

UPDATE:

I was able to test the filter permission command via Powershell (Admin) on my wireless all-in-one computer. Command worked well - did not use/require quotes around the targeted SSID.

Eliminated 2 of about 15+ wireless networks around my house. So far the two networks have not reappeared.
 
Last edited:

Enthir

Reputable
Oct 29, 2016
6
0
4,510
0
Problem Solved! Wonderful! Thank you my friend Ralston18.

Now I tried the netsh command without quotes and it is successful.

I am a person with a very little knowledge in computers. Originally, I had tried the way suggested in
https://answers.microsoft.com/en-us/windows/forum/all/how-to-block-unknown-wi-fi-network-from-appearing/027345e8-899e-413c-957b-0279a866c5d6

Then went by the way suggested by you (that is, giving the name of the wifi without quotes) and now the blocked names are not appearing in my computer.

Thank you so so much.

(Sorry for the delayed reply. Had to be away from the computer for some time.)
 

ASK THE COMMUNITY

TRENDING THREADS