Wireless repeater not working with second router


Jan 17, 2012
The setup: My main router is a Belkin N. It is the DHCP controller. I have another Belkin N router connected by CAT5/RJ45, and DHCP is turned off. Each router has a different SSID, and WPA2//AES/TKIP is the security. The purpose of the second router is to act as an access point and extend the wireless range. Now I need to extend it further, but without through wireless. I had a G bridge connected to the second Belkin, and it in turn connected to a third router which was G. This worked but was sporadic. I bought an Amped SR150 N repeater to replace the bridge and third router.
The repeater will connect to the second router with no problem. It shows the IP of the main router as the gateway IP. The laptop that the repeater is connected to then received an IP from the main router. However, the laptop has no internet. It also will not go to the IP of the main router.
I tested the repeater by connecting it to the main router. That works fine, and the laptop gets internet. I tested the second router capability by connecting the laptop to it through wireless. That works fine to, and the laptop can go to the home page of both the main and second router. When I put the repeater back into the mix, the laptop does the same tihng: It gets a new IP from the main router, but no internet, and it will not go to the homepage of the main router. I have worked on this for hours, and called Amped. They are baffled.
What am I missing?

Similar threads