[SOLVED] Witcher 3 randomly freezing for 5 seconds

mangaman

Reputable
Jun 13, 2015
383
19
4,965
69
So I contacted CDprojekred about this issue and they said that is was because of my dual core Pentium G3258. The Witcher 3 needs a more powerful CPU, but before update 1.08, users have been able to run The Witcher 3 just fine on dual core CPU's. Now. it just randomly freezes for 5 seconds (more persistent in city areas). It'll be a while until I can upgrade my entire system to an AMD Ryzen CPU, so what can I do to make the Witcher 3 run better? Does anyone else have this issue on dual core CPU's? My CPU is OCed to 4GHz.

These are the things I did to try and solve the issue, but did not work:

Update GPU drivers.
Increase GPU power. (Not overclocking, just power input)
Lower game settings. (Mixture of low and mid)
Use BES battle encoder. (Made the game run even worse)
Increase CPU ring ratio to match the CPU frequency.

None of these worked. What can I do to make the game run without randomly freezing for 5 seconds. If there is no solution, I'll just wait until I get an AMD Ryzen CPU.
 

Satan-IR

Honorable
Open world games like that usually put more pressure on the CPU. Yes settings like background characters can help.

You can try and see if these help too if you haven't already: Turn off Ambient Occlusion, turn down the graphics preset to Medium, turn off Anti-Aliasing and turn down Texture Quality.
 

Satan-IR

Honorable
If you're sure this started with the update and they told you that you need a better CPU I'm afraid you can't really do anything except maybe lowering all CPU-bound graphical settings to minimum to see if it helps.

I think you'd have to wait to get the Ryzen.
 

mangaman

Reputable
Jun 13, 2015
383
19
4,965
69
If you're sure this started with the update and they told you that you need a better CPU I'm afraid you can't really do anything except maybe lowering all CPU-bound graphical settings to minimum to see if it helps.

I think you'd have to wait to get the Ryzen.
What CPU-bound graphical settings are there in the Witcher 3? Grass density, water quality, number of background characters?
 

Satan-IR

Honorable
Open world games like that usually put more pressure on the CPU. Yes settings like background characters can help.

You can try and see if these help too if you haven't already: Turn off Ambient Occlusion, turn down the graphics preset to Medium, turn off Anti-Aliasing and turn down Texture Quality.
 

yaxy123

Commendable
Aug 3, 2017
80
5
1,565
6
This really sounds like a CPU bottleneck, but if you wanna be extra sure you can run a monitoring program with graphs, wait for a spike and look if something happens like ram usage dropping e.t.c.
 

mangaman

Reputable
Jun 13, 2015
383
19
4,965
69
Open world games like that usually put more pressure on the CPU. Yes settings like background characters can help.

You can try and see if these help too if you haven't already: Turn off Ambient Occlusion, turn down the graphics preset to Medium, turn off Anti-Aliasing and turn down Texture Quality.
It did help somewhat, but the issue is still there. I'll just wait to get my Ryzen CPU.

This really sounds like a CPU bottleneck, but if you wanna be extra sure you can run a monitoring program with graphs, wait for a spike and look if something happens like ram usage dropping e.t.c.
It is a CPU bottleneck, and a pretty bad one at that. Ram usage and GPU usage all appear fine. The game is not taking full potential of the CPU. The Witcher 3 maxes out at 70% CPU usage, while other demanding games can go up to 90-100%.
 

yaxy123

Commendable
Aug 3, 2017
80
5
1,565
6
It did help somewhat, but the issue is still there. I'll just wait to get my Ryzen CPU.



It is a CPU bottleneck, and a pretty bad one at that. Ram usage and GPU usage all appear fine. The game is not taking full potential of the CPU. The Witcher 3 maxes out at 70% CPU usage, while other demanding games can go up to 90-100%.
If it's only using 70% then it seems to be a GPU bottleneck the component that bottlenecks is the one that reaches 100% when the other one doesn't. If you have hair works enabled turn that off, it's a big performance drain.
 

ASK THE COMMUNITY

TRENDING THREADS