Question With apu screen displays with apu and gpu nothing displays

Oct 14, 2020
30
1
35
0
I bought a gpu i installed it with an apu but nothing displays. But without gpu apu displays. I think its a setting in bios or something.
Its a ryzen apu and a ryzen gpu.
 

Vyrvelata

Commendable
What is the motherboard?
And yes there is option for it in bios...usually its integrated GPU only - Integrated + External - External Only.
But if its default bios... it should automatically choose external ... once there is a GPU in the PCI-E x16 main slot.
 
Reactions: Thuyen

boju

Titan
Ambassador
You are swapping the video cable to the graphics card aren't you? Because once gpu installed, and if bios hasn't been configured for multi monitor support (motherboard + gpu as said) then the dedicated graphics card will take priority, which means the motherboard's video ports are disabled.

Need exact motherboard model also.
 
Oct 14, 2020
30
1
35
0
Gigabyte B450M DS3H is the motherboard. I plugged in the video cable into both of the video ports and didnt work too.
 
Last edited:

boju

Titan
Ambassador
Page 31 in the manual, installing a graphics card will automatically disable integrated graphics. Igpu can't be enabled whilst the gpu is installed.

Next question, what graphics card is it?

If the card requires external power, is this cable connected?
 
Oct 14, 2020
30
1
35
0
Its a Asus rog strix rx570 4gb and the cable is connected. When i turn the pc on with the gpu installed it powers up but no display.
 
Last edited:

ASK THE COMMUNITY