[SOLVED] WMI Provider Host spiking CPU usage at random ?

Cat92

Commendable
Nov 27, 2019
7
0
1,510
0
So I've tried asking before, and I've since tried figuring out how to troubleshoot it myself, but I'm at a loss. My CPU will randomly hit 90%+ usage, and WMI Provider Host will be at 20%+ usage when it happens (which I know is way above what it should be). Opening programs becomes really slow, some don't function correctly (there's a couple of games that will give errors - not windows-specific errors, just for those games - if my PC has been on for a while, so I'm only able to open those after a full restart, even if I was just in one). If it goes on long enough or spikes fast enough, my computer will slow to a crawl and I have to reboot.

This has been an issue for over a year now. I've run full virus/malware checks with Kaspersky, Malwarebytes and AdwCleaner countless times. Everything comes out clean. I saw a recommendation to look at the Event Viewer and see the event IDs that are recorded for around the time I notice it happening; I've done that multiple times, but the event IDs are never the same as any open processes, even when the CPU usage is going haywire (and 9 times out of 10, it's a completely new event ID - it's only ever the same within a few minutes in the logs).

This is affecting programs opening, how certain programs function, and it's really getting on my nerves. Is this likely a software issue, and if so how do I tell? I saw suggestions on going into safe boot mode, but the problem is that I can't pinpoint exactly when or how this will happen. Sometimes my PC will be on for a few days with no issue; other times I start noticing spikes in just a few hours. I can't predict it, and I can't force whatever is happening to happen. It happens whether I'm in a game, out of a game, have programs open or not. At first I thought Chrome might have been causing it (due to how much of a cpu/memory hog it is), but it'll happen without Chrome ever having been opened since a reboot.

I've already gone through and disabled all the start-up programs I don't need (and know what they are) a long time ago. I removed any programs that I don't use period. At this point, I'm just wondering where the heck I should be looking. Is it most likely an application causing this error, and if so, how do I tell if the process IDs never match up? Could replacing my hard drive fix it? Could it be a CPU issue? I'm at a loss, and I just need to know where to look.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS