Won't recognize connection with 100mb Full Duplex

Dotol

Honorable
Nov 5, 2012
34
0
10,530
So I recently got a new computer today and it won't let me use my 100mbps of internet bandwidth. (Asus Sabertooth Z77 with an Intel 82579v gigabit lan controller) I noticed that at the LAN connection properties>Properties>Configure>Link Speed tab the 'Speed and Duplex' option was on Auto Negotiation and it was only accepting (or supporting) the 10mbps Full Duplex. When I switched it to 100mbps Full Duplex it would mark my connection icon with a red cross and when I clicked diagnose it said "Please connect your ethernet cable or your cable might be broken". So I tested my internet speed with that same cable on a different computer (laptop) and it worked with 40Mbps, so I don't think the cable is broken. Also I just recently downloaded some drivers but one was specifically for the Intel LAN controller but I'm a total noob for all of this computer stuff I don't know if it messed it up or something. Is it the motherboard that's not working correctly? What should I do?

Should I download the drivers again, if so how? :??: sorry I'm a nob :{
 

Dotol

Honorable
Nov 5, 2012
34
0
10,530
Update: I should point out that the ethernet cable I'm using is 3 years old and about 80 feet long (it goes above my roof and circles into my room). I live in Mexico so I doubt that the quality of this cable was even close to good. I point this about because I saw a site saying that to connect to a 100mbps FULL duplex your router, LAN card and cable should be able to support 100mbps full duplex. My router and my LAN card do support it but the cable is questionable. Although I just connected to the 100mbps HALF Duplex and I got 84mbps. :<
 
Your wires most likely are ok since 10 full works and even when you run half duplex it actually uses 2 pairs.

Generally auto works best especially for gig. First I would try to disable the MDI/MDIX feature on the router and/or the PC if they have it and see if it helps. Some devices didn't implement this well.

The only way to get 100 full working when you manually set it is to set both ends. If you manually set it in the PC you must manually set it in the router.