[SOLVED] X-Wing Alliance starts infinite processes

Jun 14, 2020
71
1
45
0
So, I finally got a joystick to play flight sims and other games with delicate controls. A while back, I got X-Wing Alliance and X-Wing vs. TIE Fighter (w/ the Balance of Power campaigns) through Humble Trove but I was never able to play them because I didn't have a joystick, so naturally, I was excited to finally give them a try.

However, I attempted to start up Alliance (particularly because I know XvT is mostly multiplayer) and it starts up infinite processes with no visible result. I tried messing with the compatibility settings and I Googled the issue to see if anyone had a solution. Unfortunately, I couldn't find anything.

I know the joystick works, I used it to play some flight sims and even Star Wars: Rebel Assault II and it works no problem. I calibrated it, as well, and it didn't change anything. Every time, the only way to stop it from occupying all of my RAM until it maxes out is to end the process tree in Task Manager.

Does anyone know what might be causing this and how I can fix it? I'm running Windows 7 Home Premium SP1 64-bit and as I said, I tried running it in various compatibility settings, to no avail. I didn't pay for this since I got it for free via Humble Trove, but I'd still like to figure out how to play it. I may just buy the game on GOG if I can't get it running through this version.
 

ASK THE COMMUNITY