x370 P3.40 to 3.50 Bios update wont work.

Nov 28, 2018
2
0
10
0
Im not used to bios update so it may be a silly question but yeh.
I just got me a 2700x ryzen cpu and i got a x370 mobo ( asrock fatality k4 pro ) i know i could have buy a x470 and never had this problem but i think it doesnt worth the hassle when i already got x370 and just need to update bios.

alright now my issue is i need to update my bios from 3.40 to 3.50 and then 4.80 but im stuck at the first task which is update it to 3.50.also the instant flash file from asrock is just 1 little file so i wonder if its just a joke compare to the window
i tried to instant flash with usb but it said (No image Files detected)
then i tried with window but it stop saying (rom file romid is not compatible with existing bios romid)

i found a couple of thread talking about those two issue but none match with mine or are just way too old for the ryzen platform

i hope i dont break any rule im not used to forum and tom's hardware sorry if i.
Ty in advance for a solution.
 

ASK THE COMMUNITY