x4 4GB RAM Sticks, Windows only showing 8GB. Speccy & CPUZ showing 16GB.

Skeeno

Commendable
Mar 20, 2016
1
0
1,510
0
Hello,

I recently bought some Corsair CMZ8GX3M2A1600C9 Vengeance 8 GB (2 x 4 GB) DDR3 1600 Mhz sticks (Ordered on 19 March 2016) to go alongside my current two Corsair CMZ8GX3M2A1600C9 Vengeance 8GB (2x4GB) DDR3 1600 Mhz sticks (Ordered on 30 November 2015)

I have tested both sets in separately and both times, Windows and my BIOS have detected 8GB. When I put all 4 in, it still is only detecting 8GB - however, Speccy and CPUZ are detecting 16GB.

I then tried two of the sticks in different channels and both work still.

Any help would be greatly appreciated!



 

Tradesman1

Titan
Moderator
Try with 1 set in slots 1-3 from CPU, and tell us what Task Manager shows _ whether 4 or 8, if only showing 4, what CPU cooler are you using (it may be too tight in a corner or side and you may be 'losing' a channel. Will want to loosen the cooler then snug down screw tight
 

JBRONCFAN

Reputable
Jul 24, 2015
197
0
4,710
6
I'm not saying what fixed me will fix you. What I am saying after you get past all the possible Windows and BIOS "fixes", pull your CPU and check for bent pins. THAT is exactly what was wrong with my rig and everything is perfect now. Spent two days trying everything but pulling the CPU.

I was lucky enough to have a jewelers loop (small mag glass) that helped immensely. Got the loop off Amazon for like $5. Good luck.
 

Gino_3

Commendable
Sep 29, 2016
1
0
1,510
0
hey i have the same mobo how did u fix it i have exactly the same problem windows says 8 gb bios says to windows also says im only using 2 out of 4 slots while im using all four. cpu-z detects all of them tho
 

Similar threads


TRENDING THREADS