• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

[SOLVED] X470 CPU light and Ram lights on, not displaying

Aug 19, 2019
1
0
10
0
I’m a first time builder.

Ryzen 3600x
X470 Pro Carbon

Can’t figure out why I can’t get rid of the cpu and ram red lights and not display being shown. Any advice would help!
 
First Step:

Is your mainboard's BIOS new enough (ie., a version near or slightly after 7 Jul 2019) to support Ryzen 3rd gen CPUs? (If not, there will be no POST/power-on display)

Many in this predicament would need a 1st or 2nd gen Ryzen to be able to flash the BIOS to support the later version, unless your MB is one of the lucky few that support BIOS updates with no CPU installed...

FYI, you will need at least one RAM stick, and a functioning GPU installed, as since your CPU does not have integrated graphics support, the mainboard's HDMI/DVI would not be functional
 
First Step:

Is your mainboard's BIOS new enough (ie., a version near or slightly after 7 Jul 2019) to support Ryzen 3rd gen CPUs? (If not, there will be no POST/power-on display)

Many in this predicament would need a 1st or 2nd gen Ryzen to be able to flash the BIOS to support the later version, unless your MB is one of the lucky few that support BIOS updates with no CPU installed...

FYI, you will need at least one RAM stick, and a functioning GPU installed, as since your CPU does not have integrated graphics support, the mainboard's HDMI/DVI would not be functional
 

ASK THE COMMUNITY

TRENDING THREADS