[SOLVED] X570 aorus master, 2 8 pin connectors help

4L3

Nov 16, 2019
4
0
20
1
I recently bought a x570 aorus master and realised that my psu 2x4pin connectors labeled CP and U1 are too short to reach the atx12v connector. As i already had 1 extension cable i went ahead and connected it. Pc doing fine but noticed that my cpu(ryzen 7 3700x) is clocking at 0,8ghz and figured that my problem is that i haven’t connected my other 4 pin connector so i went ahead and bought a second extension cable. Now i realized that my cable doesnt fit. Cable only fit on the right side of the atx12v connector and leaving 4 pins on the left unused and unmatched. But this mobo has 2 8 pin cpu connectors (ATX_12V/ATX_12V1) and thats why im wondering due to both connector only fits on the right side is it fine if have both 4 pin connectors connected to each atx12v connector


Can add that my extention cables are
square,oval (top)
oval,square(under)

Mobo Left 4pin: oval, square(top)
square,oval(under)
 
Last edited:

4L3

Nov 16, 2019
4
0
20
1
Why can't they reach the connector? Normally cables provided with the psu should be long enough if routed correctly to just plug in
My PSU is arond 5 years old and the cable only needed like 0,5mm more of lenght and tried multiple routes around my case. Eitherway to answer my own question: I tried it and it works. Clocks around 4,3ghz with temps around 45-60 C
 

4L3

Nov 16, 2019
4
0
20
1
Why can't they reach the connector? Normally cables provided with the psu should be long enough if routed correctly to just plug in
My PSU is arond 5 years old and the cable only needed like 0,5mm more of lenght and tried multiple routes around my case. Eitherway to answer my own question: I tried it and it works. Clocks around 4,3ghz with temps around 45-60 C
 

ASK THE COMMUNITY

TRENDING THREADS