Question x570 aorus master debug code 07 dram led light on

Jun 4, 2019
2
0
10
0
I'm having trouble booting up my 3700x on a x570 aorus master mobo. I have a debug code 07 with a dram led light on. I've tried different sticks of ram both slots 16 gb (8x2) and I still can't get it to boot. I'm running bios version F5K. It was working fine with a gtx 970 then I upgraded to a evga 2070 super.

The first time it happened it took awhile before it booted but the display driver needed to be reinstalled, but now I can't get it to boot after changing the ram sticks and trying both slots. I may think the mobo is dead, but I'm open to ideas and suggestions before I exchange it for a new one.
 
Dec 8, 2019
1
0
10
0
So I have an official solution for the Debug Error code 07 on post. YES it is a RAM related issue. I struggled with this problem for a week before I came to a realization. So let me tell you the trouble steps I took.

So here's the issue I was running into:

First, The specs of my brand new build:

Ryzen 7 3800x
Wraith Prism (Stock heatsink for the CPU)
MSI MEG x570 Ace (Don't get me wrong, yes it's MSI but the debug codes I think are all the same)
32GB DDR4 3600 G.Skill TridentZ Neo RGB (2x16GB)
AMD PowerColor Red Devil 5700xt
ThermalTake ToughPower Grand 80+ Gold 750w
1TB Inland m.2 Gen4 drive
Windows 10 64-bit Pro
1st Bios to Newest Bios (tested each one for flaws/issues)

The issue I was running into:
As I built the system, I put my RAM into A2/B2 slots according to the Mainboard Manual specifications for Dual Channel operation. Hooking everything else up and turning the system on for the first time, the Debug LCD went through a variety of debug codes quite fast then paused at 07, went through more codes, stopped at 07 and the diagnostic LED for the DRAM next to the 24pin power port on the mainboard was on as well. System would not boot or complete the post.

Steps took towards resolution

I obviously did some research online for a week straight to find no help whatsoever in solving the problem. The advice I got from doing my due diligence and researching the hell out of the Debug Error 07 code, I found the below answers.

It's a RAM issue, right? So it's OBVIOUSLY Bad Ram. This IS a possibility, but if you've already tried the below steps, read on. It was NOT my solution.

RAM Issue: So swapped out the RAM, right? Of course I did. Did I check the QVL compatibility list for my mobo, Of course I did. 100% compatible.

1) I tried swapping the ram from A2/B2 to A1/B1. STILL no post.

2) I tried SWAPPING THE ram modules to A1/A2, HOLY sh*t It posted and booted no problems! Well, one problem existed now. IT WAS ONLY SINGLE CHANNEL!!!!! Which means my ram was running at 2133Mhz instead of 3600Mhz. This is a NO GO.

3) Just for sh*ts and giggles and for further diagnostic testing, I swapped the RAM to B1/B2 slots, It's a Code 07 again with the DRAM Diagnostic LED on.

4) The system had no problems or crashes or stutters running on A1/A2 in single channel, so I didn't think it was the ram, but the easiest resolution was to swap out the ram at the store, so I did. STILL the exact same issue. No Post/Boot and Code 07 with the Diagnostic LED for DRAM on.

The DRAM diagnostic LED was still on, the Post code on the LCD display was still 07, no post/boot. Couldn't get past 07 or the DRAM led with the new RAM either or forced to run in single channel only, which was not gonna be acceptable.

So if it's not the RAM and the mobo is having the exact same issue with the new ram in every step, it MUST be the Mainboard, right? It's a VERY Good possibility, but again STILL not the solution for me. Here's the steps I took for the mobo:

1) I swapped out the mobo, plugged in all the cables. flashed the firmware using the Flashback USB port.

2) I repeated all the steps in the RAM testing above with the new pair of RAM modules.

I got the exact same results as above. So What the HECK! If it's not the RAM and it's not the motherboard, what else is there? It's a RAM issue, right? So it's gotta be EITHER the RAM modules themselves or the Ram slots on the motherboard are bad, right? Well, read on.

After doing some more research, I discovered that the "MEMORY CONTROLLER" is built onboard the CPU of the newer Intel and AMD CPU's...

Could it be? Could it possibly be that the Memory Controller on the CPU itself is bad and that is why the B-Channel of my RAM slots would never function and would prevent the system from booting/posting successfully?

Infact, the answer to this question is YES!!! A Resounding YES!!!

I swapped out my Brand new (week old) Ryzen 7 3800x with a brand new one exchanged at the store and all my problems are GONE!! System works flawlessly, I now have my RAM working not only at 3600Mhz but they're overclocked to 4400Mhz with no issues whatsoever.

I know this is an older post, but it's one of the first that pops up on google and apparently this problem still exists from time to time, so I wanted others to be able to see it, whether you run a Gigabyte, Asus, ASRock, MSI board, etc...Hopefully I can help put this problem to rest for a LOT of people.

Now granted, I speak of B-Channel slots only because that was MY case scenario. In all honesty, If the Memory controller of the CPU is bad/defective or goes bad along the way, It can cause any variety of RAM problems, such as BSoD's, crashes, memory errors, DRAM diagnostic LED and even post codes relating to the RAM.
----------
Where you are I've been
Where you're going I've already gone
What you're doing I've already done
What you're looking at I've already seen
----------
TJ The DJ of Tech
 

ASK THE COMMUNITY