Question X570 Aorus Master not booting from Aorus Gen4 m.2 drive

Feb 21, 2021
1
0
10
0
Upgraded current build. Installed motherboard in question and used a AMD Ryzen 5 to update BIOS to F33c then installed a Ryzen 7 CPU instead.

inserted the m.2 drive and booted with windows 10 installation stick, installation went well and even got computer to go through initial setup and computer was accessible. Went to have it go through windows updates, when it rebooted motherboard would not boot from m.2 drive anymore. Motherboard recognizes it and lists it in boot options, m.2 is even accessible if i put my previous boot drive in and shows that windows is installed.

The issue here is that the motherboard will no longer boot from the m.2 drive, What can i do to get the motherboard to recognize and boot from that m.2?. Ive seen a few similar issues on this board, though im not sure they would be applicable to my board.
 

avg9956

Commendable
Apr 7, 2019
53
2
1,535
0
A little late for reply but I would just like to add there are people who are still experience issues with that motherboard even with BIOS Updates and the latest physical rev 1.2:

Try clearing the cmos by removing the battery and putting it back. It is said to be the only temporary solution, but effectively all the boards are "defective" until Gigabyte fixes it by shipping another new physical revision at their expense.

The root cause is likely to be electrical/physical in nature. Perhaps an undetected design flaw.
I personally know someone who has issues with that motherboard as well.
Among all the X570 boards from all the other brands, Gigabyte's X570 motherboard lineup seems to be plagued the most.

I would only try going for stable BIOS as of the moment. You can know if a BIOS is beta or not if it ends with a letter (i.e. F33c is a beta BIOS).
 

ASK THE COMMUNITY

TRENDING THREADS