Sep 20, 2021
3
0
10
0
Hey all, I recently changed my motherboard, cpu and ram and everything works fine if I insert the GPU into the 4th PCI slot but the VGA light comes on and stays on in the first slot. The EZ debug light for VGA goes off anytime the gpu is plugged in the top slot (16x) over the bottom (4x). I should also note that when the GPU is plugged into the E1 slot, I get a VGA debug light. The GPU is also less audible when I plug into E1 unlike when I plug it into E3 where you can clearly hear the GPU fans spin aggressively. The first slot is not damaged because the gtx 950 card inserted in the first slot works and starts the system. Any idea what I can do friends :/?
Motherboard: MSI MAG X570 TOMAHAWK WIFI
SSD: x1 Samsung 970 EVO Plus NVMe M.2
CPU: AMD Ryzen 5900X
RAM: 32GB Patriot Viper Steel DDR-4000 Kit 4x8
GPU: MSI GeForce GTX 1080 GAMING X+
BIOS Version: 7C84v17
 
Sep 20, 2021
3
0
10
0
Hey all, I recently changed my motherboard, cpu and ram and everything works fine if I insert the GPU into the 4th PCI slot but the VGA light comes on and stays on in the first slot. The EZ debug light for VGA goes off anytime the gpu is plugged in the top slot (16x) over the bottom (4x). I should also note that when the GPU is plugged into the E1 slot, I get a VGA debug light. The GPU is also less audible when I plug into E1 unlike when I plug it into E3 where you can clearly hear the GPU fans spin aggressively. The first slot is not damaged because the gtx 950 card inserted in the first slot works and starts the system. Any idea what I can do friends :/?
Motherboard: MSI MAG X570 TOMAHAWK WIFI
SSD: x1 Samsung 970 EVO Plus NVMe M.2
CPU: AMD Ryzen 5900X
RAM: 32GB Patriot Viper Steel DDR-4000 Kit 4x8
GPU: MSI GeForce GTX 1080 GAMING X+
BIOS Version: 7C84v17
Sure, here:
 
Sep 20, 2021
3
0
10
0
EDIT2:
I was able to run the graphics card in the first slot by changing the PCIE generation to 2.0
After changing to generation 3.0 or 4.0, the board does not detect the graphics card. Clearly the problem lies with the motherboard. Does anyone have an idea what's going on? As a last resort, my question is what is better: gen 2.0 x16 or gen 3.0 x4?
 
EDIT2:
I was able to run the graphics card in the first slot by changing the PCIE generation to 2.0
After changing to generation 3.0 or 4.0, the board does not detect the graphics card. Clearly the problem lies with the motherboard. Does anyone have an idea what's going on? As a last resort, my question is what is better: gen 2.0 x16 or gen 3.0 x4?
Please read this until the end.

Could you try nvflash (download it, unzip it and copy to C)?
you should try this command (since there is 2 pcie cards) step by step:

run cmd as admin, type cd /x64

-nvflash --list and see which index is the 1080, this is for example:


-nvflash --protectoff

-nvflash --index=(index of 1080) -6 biosname.rom

Here is 2 rom, make sure to choose one of them which matches all the IDs
https://www.techpowerup.com/vgabios/191740/MSI.GTX1080.8192.170330_1.rom
https://www.techpowerup.com/vgabios/191386/msi-gtx1080-8192-170330

They have different SHA and MD5 hash, but everything the same, just make sure you pick the correct one, if there is no checking, then go with either both of them

Also before you do this, Disconnect from internet, uninstall nvidia drivers using DDU, proceed to device manager and go to processors, uninstall all of them (should be 24 in yours) and uninstall them like this (when it request for restart just click NO and proceed uninstall the rest):


After that reboo to bios, and proceed update the mobo bios (while 2 cards are still there) to the latest, then load optimized/default settings, save and exit, boot to windows and install the latest amd chipset driver, then reboot to windows again.

then proceed doing the nvflash steps above.

after doing the nvflash, reboot to windows as instructed, then reboot to bios, and set the x16 to pcie 2.0 since it's the last known work mode for 1080, save and exit, then shut down, change the 1080 to top slot, and try if it boots fine.

If it does boot fine, try to go to bios and change it to pcie 3.0 or auto. and if it worked, then proceed go to windows and install the latest driver. also check for the latest windows update and optional updates, install them all.

I hope you understand :D

Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:


Also check in the graphics settings if there is Hardware Accelerated Graphics Scheduling, and enable that then reboot the pc.
 
Last edited:

ASK THE COMMUNITY