Question Xeon e3 1270 in chinese b75 won't give a signal

Apr 9, 2021
4
0
10
0
Hello Tom's users, I got a problem with a CPU I bought on Ali.

My specs are:

I5 3470
Kllisre B75
XFX RX 480
12GB RAM 1333 mHz
SSD Kllisre M.2 512gb
EVGA 600w

I bought the m.2 ssd along with a Xeon e3 1270 which is also LGA 1155, as well as my motherboard is. However, whenever I try to run a Xeon on it, my e3 1270 or the e3 1220 that I got for testing gives any monitor signal. It works fine with i5 tho.
Pc turns on, KB&M lights turn on, but can't make it give any signal. Would appreciate any help


system image:
 
Apr 9, 2021
4
0
10
0
Just like i3/5/7, there are multiple generations of Xeon.

Is this motherboard compatible with that particular Xeon?
yeah man, xeon e3 1270 is the same gen that my mobo and therefore same gen as my processor.

e3 12xx and e3 12xx v2 are supposed to work with LGA 1155 mobos, since they are versions of IX 2xxx and IX 3xxx without integrated graphics and with less tdp
 
Apr 9, 2021
4
0
10
0
Hello Tom's users, I got a problem with a CPU I bought on Ali.

My specs are:

I5 3470
Kllisre B75
XFX RX 480
12GB RAM 1333 mHz
SSD Kllisre M.2 512gb
EVGA 600w

I bought the m.2 ssd along with a Xeon e3 1270 which is also LGA 1155, as well as my motherboard is. However, whenever I try to run a Xeon on it, my e3 1270 or the e3 1220 that I got for testing gives any monitor signal. It works fine with i5 tho.
Pc turns on, KB&M lights turn on, but can't make it give any signal. Would appreciate any help


system image:
After more than a month using my i5 3470 while I didn't have spare time to fix the issue, I just got back on trying some more few things and I made some progress, but still need some help.

Updates:

  • basically the Xeon E3-1270 works fine if combined with the old GT-710 I have.
  • still, I haven't figured out how to make it work with my RX 480.
therefore, it checks out the incompatibility possibility. Here is what I have already tried to do with the xeon installed and working: DDU all graphic drivers, disabling integrated graphics on bios (the xeons do not have one), updating drivers and booting in safe mode.

I waited 15 days for this mf and it's been more than a month since it arrived, I NEED to make it work lol
 

ASK THE COMMUNITY

TRENDING THREADS