Question XFX Radeon RX 570 RS No Video Display No Post No Power

Oct 14, 2020
3
0
10
0
Ok....I'm sure this isn't the first to ask this question. Did a build the other day and PC would power on CPU fan and hard drive would spin but no POST no Video and no error beeps. So I unplugged the PC , removed the RAM and Video Card and re-seated them check the CMOS battery, Plugged back in PC power and nothing. No Power, No Post, No Video...nothing. cannot get the PC to even turn on.

Below are my PC specs. Any tips or tricks would be greatly appreciated. I'm thinking something with the BIOS?

GAMEMAX Power Supply 850W Fully Modular 80+ Gold Certified with Addressable RGB Light - Vairous Color Mode, RGB-850
ASUS TUF B450-PLUS Gaming AMD AM4 (3rd/2nd/1st Gen Ryzen ATX Gaming Motherboard(Digi+VRM, HDMI 2.0b,USB 3.1 Gen 2, Pre-Mount I/O Shield and Aura Sync RGB Lighting)
XFX Radeon RX 570 RS XXX Edition 1286MHz, 8gb GDDR5, DX12 VR Ready, Dual BIOS, 3xDP HDMI DVI, AMD Graphics Card (RX-570P8DFD6)
Asus AM4 TUF Gaming X570-Plus (Wi-Fi) ATX motherboard with PCIe 4.0, dual M.2, 12+2 with Dr. MOS power stage, HDMI, DP, SATA 6Gb/s, USB 3.2 Gen 2 and Aura Sync RGB lighting
Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3200MHz C16 Desktop Memory Kit - Black
Seagate BarraCuda 2TB Internal Hard Drive HDD – 3.5 Inch SATA 6Gb/s 7200 RPM 256MB Cache 3.5-Inch – Frustration Free Packaging (ST2000DM008)
AMD Ryzen 5 3600X 6-Core, 12-Thread Unlocked Desktop Processor with Wraith Spire Cooler
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS