Question Xonar AE Soundcard drivers gone wrong

May 6, 2021
This has been a 6 month saga of fighting my soundcard to get it back to its original glory. If you have even a slight idea of what is going on, I am desperate for help.

My soundcard is not showing up in Windows. It used to work totally fine, until about 6 months ago where upon rebooting my computer, it was nowhere to be seen on device manager.

Initial specs are as follows:

Intel i5 7600k
ASUS Prime Z270-P
XONAR AE sound board

What happens:
When the computer is functioning normally, with the sound card working properly, rebooting the computer makes it forget that the sound card is installed. Attempting to uninstall and reinstall the drivers does not work, as ASUS' Driver installation tool performs a hardware check before finishing the installation. According to the installer, the soundcard is not there.

What I've tried:
Uninstalling the drivers and reinstalling them. Uninstalling ALL audio drivers rebooting and then attempting to reinstall, power flushing the device, resetting the CMOS, updating the BIOS, updating Windows, moving the soundcard to a different PCI slot, testing the soundcard in another device, rolling back generic audio drivers...
The list goes on, I can't remember everything I have tried, but that's a decent chunk of the steps I've tried.

What I haven't tried:
Factory reset, Windows reinstall, replacing the device.

Additional information:
I am avoiding factory resetting as much as I can. Ironic as it is having a decent rig, my internet is about as bad as it comes.
Upon running PCI-Z, a tool that scans for PCI devices, 2 items are missing from the list when the soundcard is removed from the computer. ASM1042A USB 3.0 Host Controller, and 200 Series PCI Express Root Port #7.
-This leads me to believe that windows knows the device exists, but is not sure how to handle it?

ASUS Support does not know how to help, the extent they were able to tell me is to reinstall the drivers.
Windows Support does not know how to assist, after going through all their troubleshooting steps, they referred me back to ASUS.

If any information more is needed, I will provide it as soon as I am able.
Thanks in advance for any help!


Welcome to the forums, newcomer!

What I haven't tried:
Reset's don't do anything actually. Reinstalling the OS would be a good idea. I'd advise on making sure your installer isn't corrupt by fabricating your bootable USB installer using Windows Media Creation Tools.

Just for the sake of relevance, can you state what BIOS version you're on(the BIOS version number).

You forgot to mention the make and model of your PSU and it's age. Also, include the make and model of your storage. As for driver installations, always install drivers in an elevated command, i.e, Right click installer>Run as Administrator. Yes that includes chipset and every other driver out there for your platform/motherboard. Speaking of motherboard, you should download all the latest drivers from Asus's support page for the motherboard and have them on a pen drive. Once you've installed the OS, disconnect from the www, manually install all drivers.