XP setup doesn't identify SATA drive

Ron

Distinguished
Apr 1, 2004
992
0
18,980
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I've been using a 160GB SATA drive off a SIIG controller card for
several weeks as a backup drive and have decided to make it my XP boot
drive, but have encountered a problem with the XP install. During
setup, the SIIG driver is accepted, but at the partitioning screen,
setup says "there is no disk in the drive" and shows the drive as
"157066MB disk 0 at Id 0 on bus 0 on si3112 (MBR)". The next screen says
"setup must write some startup files on this disk. However, this disk
does not contain a Windows XP-compatible partition." When I create a
partition and select it, I get the same message. Before starting the
install, I disconnected my IDE drives and enabled SCSI/ATA 100 in the
BIOS. What else should I try?
 

bar

Distinguished
Apr 10, 2004
1,144
0
19,280
Archived from groups: microsoft.public.windowsxp.hardware (More info?)

SO many different SATA controllers and mobos, no definite proceedure for ALL
combinations. Yes, one expects simply to 'set BIOS' to enable SATA and also
then to prepare a driver disk for XP install.

For just what exact BIOS settings and driver files are required, you should
follow the user manual for the Mobo / SATA Controller.

If you don't have this, visit the manufacturer's website or else phone their
tech support.

"Ron" wrote:

> I've been using a 160GB SATA drive off a SIIG controller card for
> several weeks as a backup drive and have decided to make it my XP boot
> drive, but have encountered a problem with the XP install. During
> setup, the SIIG driver is accepted, but at the partitioning screen,
> setup says "there is no disk in the drive" and shows the drive as
> "157066MB disk 0 at Id 0 on bus 0 on si3112 (MBR)". The next screen says
> "setup must write some startup files on this disk. However, this disk
> does not contain a Windows XP-compatible partition." When I create a
> partition and select it, I get the same message. Before starting the
> install, I disconnected my IDE drives and enabled SCSI/ATA 100 in the
> BIOS. What else should I try?
>