Question Xpg primer mouse doesn't work

May 25, 2021
20
1
15
0
Hi fellas.Yesterday i reinstalled my windows.So i decided update my mouse firmware and i downloaded driver from xpg offical site.So when the finished update my mouse didnt work.I can see my mouse at device manager.I tried my mouse from another computer but mouse didnt work there.Can you help me ?
I tried;
Update my bios
sfc/scannow ,DISM
 

Lutfij

Titan
Moderator
I went through the support page for the mouse, here, though I can't seem to find any reference that the mouse needed a firmware update or if there is a firmware update to be found. For the sake of relevance, can you walk us through how you updated the firmware on your mouse?

As for your OS, mind sharing which OS you're on at the time of writing and where you sourced the installer from? Make and model of your motherboard and the BIOS version at the time of writing?
 
Reactions: bogisama
May 25, 2021
20
1
15
0
I went through the support page for the mouse, here, though I can't seem to find any reference that the mouse needed a firmware update or if there is a firmware update to be found. For the sake of relevance, can you walk us through how you updated the firmware on your mouse?

As for your OS, mind sharing which OS you're on at the time of writing and where you sourced the installer from? Make and model of your motherboard and the BIOS version at the time of writing?
https://event.xpg.com/prime/index.html ı downloaded here.Iam using windows 10.I have gigabyte b450m H and my current bios version F3
 

ASK THE COMMUNITY

TRENDING THREADS