XPG SSD Not Recognized on Asus Laptop

Apr 29, 2018
1
0
10
0
I'm aware of the many threads and posts out there related to drives not being detected, however I haven't come across one which solved my problem.

I currently own an Asus X756UB laptop running Windows 10 Home (latest update) which allows for expandable storage with an M.2 slot. I've decided to add additional storage so I purchased an ADATA XPG SX6000 (256GB) which is labeled to be NVMe.

After installation, the SSD is undetected in the BIOS and I'm unable to create a partition. The SSD is not faulty as I've installed it and created a partition through my PC.

I've tried a few things, such as updating my BIOS, checking to see if there's an option in the BIOS which would disable the drive, and create a partition on my PC to see if for some reason that the drive not having a partition was the problem (Which I had very low hopes for).

I've searched quite a bit of time to find a manual for my laptop (Asus X756UB), but with no luck, the manual says nothing about the M.2 slot.

Is there any other testing (BIOS or in Windows) I can do? Could it be the slot/SSD is incompatible?

Any and all help would be greatly appreciated!
Thanks.
 

ep7

Apr 21, 2019
1
0
10
0
vector10f - there is a difference between m.2 and NVMe m.2. The former uses a SATA interface, while NVMe m.2 uses a PCIEx4 interface (which is 4 times or more faster than the SATA interface). NVMe m.2 is a newer technology.
Given the age of the ASAS X756UB, you most likely need the "regular" m.2 drive card which uses the older SATA interface, which has two notches in the card.
Have a listen to this video on youtube:
View: https://www.youtube.com/watch?v=fJCHx7mZEKo
(start from the 1/2 way point) to get a detailed explanation of what you are probably running into...
I think you bought the wrong card, which is not necessarily backwards compatible, based on the ASUS laptop BIOS.
 

ASK THE COMMUNITY

TRENDING THREADS