Question XPS 8700 Cooling upgrade

mrowe122007

Prominent
Dec 15, 2018
3
0
510
0
i have decided to upgrade my xps 8700 with a i7 4790, switching all drives to ssd and adding a better cooler. I have watched some videos and from what im gathering dell has a bracket people have utilized with the arctic freezer 33. I didnt know if this is something i can do with my hyper 212 evo. Will i be able to utilize the bracket that is already there for the hyper 212?
 

Eximo

Titan
Herald
So what Dell has is a threaded backplate that is part of the CPU socket.

I have seen two solutions. One is to remove the metal parts of the CPU socket entirely and use the new heatsink to hold it in place. I'm not a huge fan of this method.

The other is to buy some long M3 machine screws, washers, and use that to put something like the Deepcool Gammaxx 400 or Hyper Evo 212 in place.

I have a picture of my installation somewhere.
 

Eximo

Titan
Herald

mrowe122007

Prominent
Dec 15, 2018
3
0
510
0
I actually ended up doing something else. The hyper evo ended up being to tall to install the case side door. I took it back for a smaller one (thermaltake contact silent 12), well is also too damn tall but only sticks out about a quarter inch or so lol. Im just going to cut out the area out the side door that the cooler comes in contact with, mount a filtered screen to it and call it a day. Anyways what i did to mount this cooler to this machine in particular was fairly easy with one extra step. This cooler mount goes on the inside with plastic push fasteners. The threaded inserts on the mounting plate for the original heatsink were to small for the fasteners to go through. Like the guy in this video attached at 1:45, i took the plate and set it on a vise to punch the thread inserts out which come out fairly easy with 2 or 3 hits. I had to keep the plate since the original heatsink mounting tabs and cpu hatch screws are all mounted on one single plate. My cooler seemed to need quite a bit of pressure to get the cooler on and latch the 2 latches to the mount but i didnt have any issues booting up and all worked well. On a side note since ive installed this new processor i get a occasional bad mouse lag. Dont know if this is relevant

This guy has a 8900 but the mounting bracket is the exact same

View: https://www.youtube.com/watch?v=KxbCigBDEH8&t=185s
 

ASK THE COMMUNITY

TRENDING THREADS