Yet another "It won't turn on" post... tried everything I can think of and read

ahoymatey

Reputable
Nov 26, 2015
3
0
4,510
0
Define r5 case, 4690k, Gigabyte gaming 5 mobo, 980 Ti. Built it, turned on power supply (Corsair rm850x) hit the on button, the fans get a pulse of juice and stop. That's it.

I've pulled and reseated the RAM, tried without the 980 Ti, checked that the chip is in properly, checked all cable connections several times, disconnected everything not important, and nothing. I wore a grounding strap when building it. CPU power plugged in. Oh, my external DVD drive spins up when I turn on the PSU.

All brand new gear. I don't have any spare parts to swap parts out, my first build coming from Mac.

It acts like it wants to go but shorts immediately, am I reading that right? This is also my first build so I could be missing something obvious, but I've checked all the checklists I could find, including old posts here. The case doesn't have integrated speakers so I can't hear any beeps. Plugged in external ones, they turn on but no sound.

If something is DOA, how can I narrow down the culprit?

Please help! Thanks for any brainstorming.
 

ahoymatey

Reputable
Nov 26, 2015
3
0
4,510
0
That post is how I found this forum. I have done ALL of those, checked everything. I stated above I've tried everything I could find online to check.

My current problem is my case doesn't have a speaker, so I can't hear any beeps that may be occurring. I've ordered one but it won't be here for a few days.

At this point I'm pretty sure something is DOA, but I don't know what.
 

ASK THE COMMUNITY