Question Yet another RAM speed issue.

Jul 8, 2021
4
0
10
0
First my specs, then my issue:
Gigabyte Aorus x570 Elite Wifi
Ryzen 7 5800X
Crucial Ballistix 3600 MHz DDR4 DRAM Desktop Gaming Memory Kit 32GB (16GBx2) CL16 BL2K16G36C16U4R (RED) mounted in slots A2 and B2.
Noctua NH-D15 cooler
Zotac RTX 3080ti
Samsung 970 EVO m.2 SSD 1tb
Samsung 860 EVO SSD 1tb
EVGA 1000w PSU

BIOS up to date, chipset drivers updated, XMP enabled on profile 1.

The issue: I cannot get my memory to run at anything other than 1333MHz (2666 in task manager). I've set up BIOS to XMP enabled, profile one and it recognizes the changes and restarts, yet CPU-Z, HWinfo, and task manager all say it's still only running at 1333MHz (2666MHz) and the timing doesn't change.

I'm a complete noob at messing with BIOS stuff but I've been researching and talking with people that know more and everyone is stumped. Any help would be really appreciated.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

By stating up to date, it would offer relevance if you could include the BIOS version. As for your rams, you've got them in the right slots but you might want to try with A1 and B1 as stated in your motherboard manual, page 12. Try and input the frequency, voltage and timings in BIOS manually. See if that changes your experience.
 
Jul 8, 2021
4
0
10
0
Sorry, BIOS version F34 6/10/21.

I had the same results with the RAM in A1 and B1 before switching them.

I will take a look at manual inputs.
 
Jul 8, 2021
4
0
10
0
So that had no effect. When I did restart and go into BIOS, it said that BIOS had been reset, and XMP was disabled. I hoped this was my issue, enabled it to Profile 1, saved and restarted. Same thing. So I went into Ryzen master and made the changes, applied and tested. It restarted, said the test was successful. However, TM still reads 2666MHz. No clue where to go from here other than trying to make those changes directly in BIOS.



So for reference, I changed:
memory clock from 1333 to 3600
MEM VDDIO from 1.2 to 1.35
CAS Latency from 23 to 16
Row Precharge Delay from 19 to 18
Read Row-Column Delay from 19 to 18
Row Cycle Time from 62 to 58
and RAS Active Time from 43 to 38

I made those changes based on this:
 
Jul 8, 2021
4
0
10
0
And now I'm having the BIOS reset issue whenever I restart. It sets everything back to stock, but doesn't seem like a CMOS battery issue because the date/time stays accurate?
 

vov4ik_il

Respectable
My guess is that your CPU does not support 3600, you would have to manually tune it to 3200 to be above 2666. WIth AMD CPUs the memory controller is embedded.

Edit: there are so many AMD users that would not check memory QVL for their motherboard/CPU, make the purchase, and then get frustrated putting it together, you would not be in the 1st 100 :)
 

mikewinddale

Reputable
Dec 22, 2016
274
29
4,840
24
Your motherboard manufacturer says your CPU supports up to 4400 MHz memory, so that's not the problem.

My suspicion is that one of those XMP settings is too tight for your CPU. Maybe your CPU cannot handle those tight XMP timings at that high speed.

So I'd suggest this: start with the JEDEC #14 speed and timings, but the XMP voltage. Then, try increasing the clock speed of the memory while keeping the timings loose and the voltage high. That way, you're remaining within the RAM's safe specs, but you're gradually increasing the clock speed to see what your CPU supports.

Once you reach the clock speed you want, with loose timings, try tightening the timings and see how far you can get. Don't make tighter than the XMP profile.

This way, you won't technically be overclocking. You'll just be manually trying speeds and timings in between the JEDEC and XMP profiles.

Also, the highest non-OC speed listed by your motherboard is 3200 MHz. So perhaps you can try running at 3200 MHz, then manually tighten the timings.
 

mamasan2000

Distinguished
Do you have Fast Boot enabled? Disable that. It's required for memory training. Second, your CPU ODT (on-die termination) seems high. From what I've seen, it should be in the 30s. On first gen Ryzen, maybe 48-60 but everything after that, it should be lower.
This is just an example picture I found on Reddits overclocking section: View: https://imgur.com/rYiPzh1
ODT = 37. Note also, Mem VDDIO = 0. I haven't played with Ryzen Master ever. But that zero leads me to believe it is additive. Correct me if I'm wrong. Could also be old version of Ryzen Master that wasn't compatible with his hardware and therefor not picking up any values.
If you get the RAM working, try to run with Command Rate 1. It will bring the latency down. CMD2T in Ryzen Master, can you pick CMD1T there? GearDown Mode enabled = False will bring down the latency another 2-3 nanoseconds in general but that is harder to run, doesn't always work. Enable GDM in that case.
Too low TRFC is an absolute showstopper. Doesn't matter what your other timings are, it wont boot. Try to raise it. Try like 600-700, if it boots, try lowering it by 20 -50 at a time. Til it no longer boots, then add what you lowered with. You could do it in smaller steps but that gets timeconsuming.

I just find it easier to set everything in BIOS. If it doesn't work, I wont boot. It's simple and fast that way.
 
Last edited:

ASK THE COMMUNITY