Question Z170 board doesn't recognize NVMe drive

Aug 18, 2020
1
0
10
0
ASUS Strix 1080 ti
ASRock z170 extreme 4
6600k
16gb ram (Don't know exact model, can look that up)
1 TB Crucial P1 NVMe drive
1300 watt Corsair PSU (long story)

Hello guys,

So I've basically went through almost all the threads on this issue and didn't find anything so far that could help me.

So I want to install Windows on my new NVMe drive. I removed all my old drives (an 250 gb ssd, and a 1 tb hdd), downloaded the Windows installer and installed in on an USB stick. I put the USB drive in, I set it as boot priority 1 in UEFI, I turned on secure boot, turned off CSM and saved the options and booted the USB. At this point, the drive still gets recognized as something like m2, both in the easy mode and advanced mode of the UEFI.

I followed the steps from the Windows USB installer, I could select the drive, and it succesfully installed it on the NVMe drive. Now when I go to the UEFI, I can't see it as boot option anymore. If I turn CSM on, and manually select everything in UEFI mode instead of legacy, I can see that there's still an M2 drive being recognized in there, but I can't boot from it to finish the Windows installer. It's not in the list as something like "Windows boot manager" which probably should be.

I hope you guys can help me out. If pictures are needed, I can make them from every step required.

Regards,
Jesse

EDIT: I have put the NVMe in my brothers PC and tried to install it in his PC. He has a Z370 mobo. The installation from the USB goes as planned, but the same result in his PC where there is no way to boot the NVMe after this, it also doesn't show up in the bios as bootable. Might this be a faulty unit? I've noticed it only has 928 GB instead of the usual 931 GB of space too.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS