Question z370 gaming 7 gives 18 as error

Mar 10, 2019
10
0
10
0
So, i just bought everything new from amazon: Intel i7 9700k, z370 gaming 7 , EVGA G3 750, a working HD, 970 EVO M.2 SSD, 2x 8GB gskill ram 3200 mhz and Corsair H45. The GPU is RTX 2080 but i took it out for the tests. With the GPU or without it the problem is the same.

The problem is that when i try to turn it on, it will try to turn showing some codes on the display, then it will pause at code 40 then go to 0 and go back to 18. And sits at 18 for a while then it shuts down and turns on again automatically. I tried removing RAMS and checking every cable. I thought i could installed wrongly that H45 then i switched the plugs, the fan turns on -not sure for the pump tho- but this code doesn't even let me go to post so i think the h45 wouldnt be the problem.
I read somewhere that i should update my bios so that it recognizes the processor, but i dont know how can i do this without going to post, and with the motherboard rebooting after some time. Thankss so much in advance...
 
Mar 10, 2019
10
0
10
0
That board requires bios F10 or newer. That board also needs a compatible cpu installed in order to update the bios.
Ouch... okay, i'll see what i can do. Thank you!

The Z370 motherboard doesn't have a BIOS to support the 9700k. You need a Z390 board.
Well, i re-checked a lot to see if i was crazy but it does support the 9th gen, i just didnt know i had to update the bios for it. Also, i didnt know z390 was out... My bad. But now that i have it, i'll see what i can do. Thank you!
 

ASK THE COMMUNITY

TRENDING THREADS