Question Z390 Aorus Elite doesn't recognize my RX5700 OC on the x16 PCIe port

Mar 27, 2021
1
0
10
0
Hey hello, I am very sad because I think this beautiful MOBO has died. I was using my computer since 8 months ago and right now after moving, I am not able to use my graphic card on the x16 port.

I am going to describe the problem:
When I connect my computer with my graphics card on the x16 PCIe port, it doesn't give any image to the monitor, and sometimes I got the BOOT Led on. If I change the HDMI cable to the integrated HDMI output, I got image and everything goes okay.
When I try to check the graphics card on the BIOS, it doesn't show anything at the x16 port. Windows also doesn't recognize it, I only see the UHD Graphics 630.

My first thought was "The Graphics Card died" but I tried it on the x4 port and it's working, but I think it's not a good way to use this card because sometimes I got black screens while playing. And also this is not intended to use a high-end graphics card, I won't get its maximum performance.

What I have done to try to solve it:
  • I have updated the BIOS to the last one, no luck.
  • I have updated the graphics card's drivers, no luck.
  • I have reset the BIOS/clear CMOS, no luck.
  • I have already formatted my computer, no luck.
  • I have tried with only one RAM Stick, no luck.
  • I have tried 4g decoding or something like that on BIOS, no luck.
  • I have disabled the integrated graphics, no luck.
  • I dont have any SATA connected.
  • I have disconnected my PCIe Wifi/bluetooth thing.
I don't know what to do, everything is pretty new, I cannot believe it will stop working that easy.

My specs are:
  • Gigabyte Z390 Aorus Elite
  • 32GB of RAM Corsair 3000mhz (DDR4)
  • 1TB of Samsung 970 EVO
  • Gigabyte AMD Radeon RX5700 OC (8GB)
  • i7 9700k
  • CoolerMaster AirCooler
  • Gigabyte G750H Gold Plus (750W 80gold)
The only thing I did was disconnect everything and connect everything again after some days because I was cleaning the case.
Any idea? Or do I need to buy another one?
 
Mar 21, 2021
53
6
35
0
Hi SGarcia,
Sorry to hear you're having problems, that's a nice build.
Cleaning the case - how did you do that? Canned air? Were you careful to avoid electrostatic discharge?
I think the first thing to try is reconnect everything again as per normal, but checking the cabling very carefully.
If you're very lucky you've just made some error in connecting things up, I would double and tripple check for that (including making sure that the monitor is looking for the input on the right port).
It might also be that main PCIE port is damaged - do you (or a friend) have a second graphics card you can use to test the port?
Looking at it the other way also, do you (or a friend) have a second computer you can test the graphics card on?
All the best
 

ASK THE COMMUNITY