[SOLVED] Z390 Aorus Pro new build fails when powered ?

Status
Not open for further replies.
Jan 1, 2021
1
0
10
0
I've put together a new rig, and when I plug in the PSU and power it, the motherboard's LEDs turn on for a split second, then nothing. Won't power on, but mobo's USBs will power peripherals.

The build:
Z390 Aorus Pro Wifi
i9 9900k
Corsair Vengeance DDR4 3000mhz 8gb x 2
Corsair H80i v2
Corsair RM750

So far, I've tried:
  • reseating my CPU
  • reseating my heatsink (several times)
  • powering with minimal config (mobo, cpu, psu)
  • reconnecting all power cables (tripple checking I'm using the right outlets & labelled cables)
I'm stumped. I don't know if there's something I'm missing (this is my first mobo replacement). The parts are new except for the cooling and RAM.

I have another PSU (Corsair RM 1000) that I could try, just to rule out if this new PSU is the issue, but it was in a rig where the GPU burned and it's probably faulty (planning on RMAing it).

--UPDATE--

Ok, I made a newb mistake. Problem was I'd tried pluging the f_panel connections upsidedown. Whoops. Power button works and it seems to boot fine. :D Can't beleive how long I was struggling with this before posting vs. figuring it out almost immediately afterwards
 
Last edited:
Status
Not open for further replies.

ASK THE COMMUNITY