Question Z390 Aorus Pro Wifi - no display, rebooting

Oct 15, 2019
2
0
10
0
Component List:

  • Gigabyte Z390 Aorus Pro Wifi
  • Intel Core i9-9900K
  • 4 x Corsair Vengeance DDR4 3200Mhz
  • Intel SSD 660p 1tb and 2tb (in M,2 slots 1 and 2)
  • Seasonic Focus Plus 650w PS
  • BeQuiet Dark Base 700 ATX case
  • Mugen 5 Rev B Cooler
-Gigabyte GeForce RTX 2080Ti Windfoce 11GB (not installed yet)
  • Monitor - LG WQHD display on HDMI
  • Keyboard/mouse - Logitech wireless USB
Background
This computer is almost identical to the one that was built by Carey Holzman (
View: https://www.youtube.com/watch?v=M5yh42XPnKg&list=FLDcb9T3Bo4QX-ANhRYF-0Aw&index=5&t=3439s
) so i was following his video for installation. I have not built a PC for a number of years so i was using this video to make sure i did not make any mistakes.

I installed the CPU, cooler, SSDs, RAM, power supply and then installed the MB into the case. I then connected the MB cables for power and the power/led cables from the case to the MB.

When i turned on the computer, I got the status of the CPU led coming on, and the CPU fan was coming on. However, after about 15 seconds, the PC would turn off, and then restart, and i had this continuous loop over and over again.

I have tried reseating the CPU, RAM and taken the battery out from MB etc.

I am not sure what could be wrong here. The manual says that the status lights being on means that there is a problem with that item. So in this case, it appears to be the CPU. But is there a way of checking this or some trouble shooting? the manual for the MB does not have any trouble shooting steps and i was not able to find anything specifically on point, although there are people who have had similar issues with different lights coming on.

I would appreciate any suggestions/trouble shooting steps anyone may have.

BTW, i have not got to the step of installing the GPU yet, so the monitor is connected to the MB HDMI port. I am not getting any signal on the monitor at all during the reboot process.

Thanks in advance for reading this.
 

Phaaze88

Honorable
Herald
If the cpu light is on:
-take the cooler off and the cpu out, and check the mobo socket for bent or broken pins.
-it's also possible to cause cpu errors by way of over-tightening the cpu cooler. So when you remount the cooler and are securing the screws - when they stop, you stop.
 
Oct 15, 2019
2
0
10
0
I worked this one out, it was my own carelessness. Somehow i had loosened the CPU power cable at the power supply. It was snug on the mb but not fully pushed in so that fixed it when i reconnected all cables.

Thanks for the response btw.
 

ASK THE COMMUNITY

TRENDING THREADS