Question Z390 Aorus Ultra flickering on and off

Feb 17, 2020
2
0
10
0
I've seen other threads like this, and i have even tried some of their solutions to no success so i am writing up my own to see what the experienced pc builders here have to say.

This is my first PC build and safe to say i'm at a loss. When i plug the power chord in and flip the switch i see the mother board flash its main two LED's, as well as the code light in the bottom right corner. (The Alpha-numarical code hasn't light up once in this whole process.) Then the deviece turns itself off, and after 2-3 seconds it turns itself on again and runs for another 5-15 seconds before repeating the process.

My specs are as follows:

MB: Z390 Zorus Ultra
CPU: Intel I9900KF
Cooler: Noctua NH-D15 with one Fan (Used Arctic MX-4 cooling paste)
RAM: 2x 16GB G.Skill Ripjaw DDR4 (Set up in dual channel config)
Memory: 1x Intel SSD 660p 1Tb M.2
Graphics: 1x Gigabyte 2060 Super
PSU: EVGA 700w
Case: Fractal Design Meshify C White

For what its worth, I now have two Z390's because i tried swapping it out, to no avail. Honestly i'm not sure the issue is with the MB, but i've seen multiple posts about similar issues and am at a loss. I can't get the computer to reach a bios screen even. Fans will run, but the lighting of the graphics card and fans will operate only to flicker as the device goes through its reset cycle.
 
Feb 17, 2020
2
0
10
0
Update: got a 850w PSU to test (tested with just MB and PSU, nothing else attached) If it was the power supply or cabling, but same problem still on both MB's. Wondering if it isn't a problem with the case's stock power button wiring.
 

ASK THE COMMUNITY

TRENDING THREADS