Question Z390 Gaming SLI - GbE NIC Functionality Disabled?


Nov 9, 2018
Hi there

Wondering if someone could help me out here.

I've had this board (Z390 Gaming SLI) for a few years now and today I noticed some slowness when downloading a large file.

I did some speed tests and they reported my connection to be running at 94 Mbps. This is not usual - I have a 200 Mbps line and I have always pretty much hit 200 consistently.

I use a Ubiquiti Dream Machine Pro and had a look around in the settings - Sure enough, UDM is reporting my desktop as "FE 100Mbps", so its not recognising the GbE . I'm using Windows 11 - Windows 11 also reports 100Mbps on the Interface settings

Thinking that perhaps it was a cable problem, I tried 3 different ethernet cables and it didn't make any difference.

The UDM Pro allows a speed text itself, testing my WAN speed and it reports 220Mbps which is normally what I get.

I've tried numerous other things - Such as downloading the NIC driver from Gigabyte, trying a generic Intel driver, messing around with numerous Windows settings etc. Nothing has worked.

I suspect the cause here might be due to me flashing the BIOS 2 days ago. I was running F9 and updated to F10. I've never looked in the BIOS at Ethernet settings, but trying to diagnose this I went into the BIOS and took a look at LINK SPEED (which was set to Auto-Negotiated) and it doesn't allow me to select 1000Mbps - That isn't an option. It only shows 100Mbps?

Could this be because of the BIOS update? Or could someone suggest something else?

I was thinking of activating the backup BIOS (as I can't downgrade from F10, tried ) which hasn't been touched since I bought the board to rule out the BIOS issue but wanted to see if someone had any other ideas?

Many thanks.


If you have a spare/empty drive at your disposal, I'd try and reinstall the OS onto said drive to see if there was a glitch with the OS on your existing drive. As for your BIOS, did you try clearing your CMOS, by removing the battery from your motherboard for at least 30 minutes? Prior to removing the battery, please disconnect from the wall and display(and the ethernet port).