• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question zen 2 disobeying power plan, bios settings?

infradeath

Honorable
Oct 26, 2013
19
0
10,520
1
i have a ryzen 3600 here on a gigabyte x570 ud bios f4b, that is apparently disobeying bios and power plan settings specifically such as disabling of "core performance boost", "global c-state control", "ccpc" and "minimum performance state of processor", "core parking".

using windows 10 1903, latest updates, amd chipset drivers and power plans (ryzen balanced and high performance or windows power plans). even as i disabled all settings via bios and power plan to disable things like c-states, core parking, etc completely, the cpu would still downclock and park cores. no matter what i set in bios or the power plan, the cpu just right out ignores it. even with a fixed multiplier core states, downclocking and power saving features will remain active and enforced by the cpu.

i suspect this is due to the bios / agesa microcode and / or power plan. is it safe to run the cpu @4.2ghz with 1.5v on a daily basis instead or will it degrade too fast then? even with enough thermal headroom, the cpu doesnt clock to boost speed often enough. i know this was an issue before and has been patched with the latest bios, but its still not good enough. looking forward to agesa 1004b, which hopefully fixes all of this.
 

infradeath

Honorable
Oct 26, 2013
19
0
10,520
1
Disable AMD Cool’N’Quiet to disable downclocking, low power c-states will also be disabled.

Not sure why you want to disable boost, though. What are you trying to achieve?
theres no such thing as a cool'n'quiet setting in the bios. none of the power saving or boost features can be disabled effectively, all settings are ignored by the cpu. im disabling core performance boost, because it is also responsible for downclocking and c-states. im trying to achieve to disable all c-states, power saving and boost functions and run on a fixed frequency or preferably run from a minimum stock frequency to boosted frequency (3.6->4.2) without c-states and power saving clocking down to ~60mhz and setting cores asleep / parked. rather getting the cpu to work as intended with the respective options in the bios and power plans, which it is ignoring right now.
 
Last edited:

prophet51

Great
Jun 14, 2019
111
20
95
2
Try using zenstates to disable c6 states from within windows. safest max all core voltage for zen 2 is said to be 1.325 you will degrade your cpu with your current settings.
On my 2600 if I set the power plan min frequency to 100% it locks cores to their max frequency all the time.
Are you using process lasso?
 
Reactions: infradeath

infradeath

Honorable
Oct 26, 2013
19
0
10,520
1
Try using zenstates to disable c6 states from within windows. safest max all core voltage for zen 2 is said to be 1.325 you will degrade your cpu with your current settings.
On my 2600 if I set the power plan min frequency to 100% it locks cores to their max frequency all the time.
Are you using process lasso?
i read about that safe voltage, too. currently im running with all power saving and boost features enabled, all voltages on auto. will try zenstates, is there an up to date version? btw whats the difference between pbo and automatic overclocking? what is soc uncore mode? im using process lasso, too, but no change with or without it. is there another issue using it? what would i use of values in ryzen master for ppt, tdc and edc with pbo or auto oc?
 
Last edited:

prophet51

Great
Jun 14, 2019
111
20
95
2
Yes I think you need the 0.8beta version. You can also use it to apply your overclock/volts automatically at windows start which is how I overclock my 2600.


Process lasso has features that automatically apply core parking/power profiles regardless of what you set in windows power management. You said you tried without did you uninstall?
 

infradeath

Honorable
Oct 26, 2013
19
0
10,520
1
Yes I think you need the 0.8beta version. You can also use it to apply your overclock/volts automatically at windows start which is how I overclock my 2600.


Process lasso has features that automatically apply core parking/power profiles regardless of what you set in windows power management. You said you tried without did you uninstall?
havent tried uninstalling yet, only shutdown. not sure if id would make a difference, since power plans can be applied without reboot, too, but ill try. anyway it was said that monitor or other tools make bad requests to the cpu (race condition), so i should probably leave it away. just noticed i cant even set cpu affinity over process lasso, also disabling core parking with park control has no effect, since the cpu rules over all this no matter what the software wants. even custom voltages and frequiences still dont disable c-states. no difference with clocks and or in performance with all kinds of settings and different power plans, too.

i figured to run pbo+auto oc of 200mhz now from bios with ppt, tdc and edc automatically set to max values and it does indeed clock higher and more aggressive now. what i dont understand though is that cinebench gives 4ghz boost on all cores, but playing a game roughly 3 cores are only at around 3.6ghz or even lower.

edit: uninstalled process lasso, rebooted, dont notice any change. btw vcore sits on 1.42 all the time while gaming. from zen states how to: For example, P-states don't work as expected on Zen2. Read and write operations complete successfully, but they seem to be ignored. Differences might be expected due to different AGESA and SMU versions as well.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS