Question Zotac 3080 ti issues with EK water cooling block

ATOMICBEAR9

Distinguished
Jan 23, 2014
14
0
18,510
0
Hi!

Kinda at a loss at this point. I have a new 3080 ti that I am trying to watercool with a EK waterblock. When I have the waterblock on I get little to no performance from the GPU and boot issues. When I have the stock cooler on, everything runs completely normal. My gut tells me its either a short from the block or the card not recognizing the fans and throttling speed. Has anyone else run into this issue?

This is my first watercooling build so maybe there is something I need to change in bios? I reached out to EK before purchasing this block and I was told at the time that it was compatible.

Here are the specific parts
- EKWB EK-Quantum Vector RE RTX 3080/3090 GPU Water Block, Revision 2, Digital-RGB, Nickel/Plexi
- ZOTAC GAMING GeForce RTX 3080 Ti AMP Holo
 

ATOMICBEAR9

Distinguished
Jan 23, 2014
14
0
18,510
0
If you look here;
https://www.ekwb.com/configurator/waterblock/3831109833636
there's no mention of the Zotac Amp GPU being compatible with the block, which leads me to ask, how did you end up buying the block for the GPU?
Sorry for the late response. Before I purchased the block I talked with a EK support person and they said it was compatible. Ever since I started having issues I have been in contact with their support and they have not mentioned it being incompatible.

I recently reinstalled the stock heatsink and fans. Now I can't even get a display so I might try my luck doing an RMA.
 
Oct 16, 2021
1
0
10
0
Sorry for the late response. Before I purchased the block I talked with a EK support person and they said it was compatible. Ever since I started having issues I have been in contact with their support and they have not mentioned it being incompatible.

I recently reinstalled the stock heatsink and fans. Now I can't even get a display so I might try my luck doing an RMA.
Whatever happened afterwards so far?
 

ASK THE COMMUNITY

TRENDING THREADS