Question Zotac GeForce GTX 1070 8 GB Mini Video Card (PC WONT START)

Kashif_7

Reputable
Oct 11, 2016
4
0
4,510
0
Hey everyone,

I need your assistance regarding an on-going issue. Recently i upgraded my PC 8 months back in Sept 2019 from Intel to AMD Ryzen

The PC specs are listed below

CPU
- AMD Ryzen 7 3700X 3.6 GHz 8-Core Processor

Motherboard - MSI MPG X570 GAMING EDGE WIFI

Memory - G.Skill Ripjaws V 16 GB (2 x 8 GB) DDR4-3600 Memory

Storage - Western Digital Blue 500 GB M.2-2280 Solid State Drive

Storage - Western Digital Blue 2 TB 3.5" 5400RPM Internal Hard Drive

Video Card - Zotac GeForce GTX 1070 8 GB Mini Video Card (3 Years old)

Power Supply - Antec 500 W ATX Power Supply (3 years old)

I use this mainly for gaming and netflix. Couple of days back i was playing CS-GO and the PC just died on me in the middle. It died just as I was fiddling with Nvidia's in-game filters (think it's alt+f3) for the first time (not sure if there's any connection.) When i tried to turn it back on, the PC 'power on light' will light up for a sec and turn off (See video attached). I removed the graphics card and the pc turned on immediately, so i took the GFX and put it in another pc and the same issue followed. Now I am unsure if this GFX can be fixed or is there anything else I could do to verify my claims.


Thanks
Kash (PC Gamer)
 
Last edited:

Kashif_7

Reputable
Oct 11, 2016
4
0
4,510
0
This seems like a power issue, do you have another quality power supply to test with?
So this is what i did, i have an old gtx 970, i inserted it in my pc and it works like a charm, i am posting this from the same PC.
I took the gtx 1070 card and put it on another PC which has PSU (Corsair VS 650). I get the same issue in my another PC also, the pc does not start when i insert the gfx in the PCI slot.
 
Last edited:
May 25, 2020
8
0
10
0
Sounds like a faulty card probably if another PSU is doing the same thing, and if another GPU works with mobo.
 

ASK THE COMMUNITY

TRENDING THREADS